summaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/cpu/mips/danube/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-28 22:40:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-28 22:40:32 +0000
commit60c60c05163b1d4d44fefef49caaac9dbc9f8a8f (patch)
treec3a7fa927f23cbbbf01129aec8cc729b731849bc /package/uboot-lantiq/files/cpu/mips/danube/Makefile
parent6e5419b7acc217c83d410775ae3d71d37efdaa91 (diff)
downloadmaster-31e0f0ae-60c60c05163b1d4d44fefef49caaac9dbc9f8a8f.tar.gz
master-31e0f0ae-60c60c05163b1d4d44fefef49caaac9dbc9f8a8f.tar.bz2
master-31e0f0ae-60c60c05163b1d4d44fefef49caaac9dbc9f8a8f.zip
add uboot-lantiq (based on a patch contributed by Lantiq)
SVN-Revision: 20561
Diffstat (limited to 'package/uboot-lantiq/files/cpu/mips/danube/Makefile')
-rw-r--r--package/uboot-lantiq/files/cpu/mips/danube/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/uboot-lantiq/files/cpu/mips/danube/Makefile b/package/uboot-lantiq/files/cpu/mips/danube/Makefile
new file mode 100644
index 0000000000..c48d02eaaa
--- /dev/null
+++ b/package/uboot-lantiq/files/cpu/mips/danube/Makefile
@@ -0,0 +1,46 @@
+#########################################################################
+#
+# (C) Copyright 2000-2006
+# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+
+include $(TOPDIR)/config.mk
+
+LIB = $(obj)lib$(SOC).a
+
+COBJS = clock.o
+
+SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c)
+OBJS := $(addprefix $(obj),$(SOBJS) $(COBJS))
+
+all: $(obj).depend $(LIB)
+
+$(LIB): $(OBJS)
+ $(AR) $(ARFLAGS) $@ $(OBJS)
+
+#########################################################################
+
+# defines $(obj).depend target
+include $(SRCTREE)/rules.mk
+
+sinclude $(obj).depend
+
+#########################################################################