summaryrefslogtreecommitdiffstats
path: root/package/uboot-envtools
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-11-01 09:23:29 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-11-01 09:23:29 +0000
commitdf4579dc6471ca32ccee9f1b8be43fd98565a70c (patch)
tree2f82d911ebe7abb3173f24e8b7fff9462656288c /package/uboot-envtools
parent3ac119b8cfbbe692b453917e4d9f9ff2ab16ad44 (diff)
downloadmaster-31e0f0ae-df4579dc6471ca32ccee9f1b8be43fd98565a70c.tar.gz
master-31e0f0ae-df4579dc6471ca32ccee9f1b8be43fd98565a70c.tar.bz2
master-31e0f0ae-df4579dc6471ca32ccee9f1b8be43fd98565a70c.zip
package/uboot-envtools: make fw_setenv symlink optional
Make the creation of the fw_set-symlink optional, so it can be disabled in user-builds so only people who know what they are doing will mess with uboot-env. Signed-off-by: Daniel Golle <dgolle@allnet.de> SVN-Revision: 28698
Diffstat (limited to 'package/uboot-envtools')
-rw-r--r--package/uboot-envtools/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/package/uboot-envtools/Makefile b/package/uboot-envtools/Makefile
index 19aebc215f..adb2aeabb4 100644
--- a/package/uboot-envtools/Makefile
+++ b/package/uboot-envtools/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
PKG_VERSION:=2011.06
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
@@ -32,10 +32,17 @@ define Package/uboot-envtools/description
This package includes tools to read and modify U-Boot bootloader environment.
endef
+define Package/uboot-envtools/config
+ config PACKAGE_uboot-envtools_setenv_symlink
+ bool "create fw_setenv symlink"
+endef
+
define Package/uboot-envtools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fw_printenv $(1)/usr/sbin/
- ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
+ifneq ($(CONFIG_PACKAGE_uboot-envtools_setenv_symlink),)
+ ln -s fw_printenv $(1)/usr/sbin/fw_setenv
+endif
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/uboot-envtools.init $(1)/etc/init.d/uboot-envtools
endef