summaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-13 17:15:27 +0200
committerJohn Crispin <john@phrozen.org>2016-06-13 22:51:43 +0200
commit6ccf400be12800d6d52be2c0c43f53d80a443033 (patch)
tree59acf702bef785f6786f2701ef197baf9a3e1f2b /package/system
parentfd7e15d493166eeed15153caa864a9cc59e3a51a (diff)
downloadmaster-31e0f0ae-6ccf400be12800d6d52be2c0c43f53d80a443033.tar.gz
master-31e0f0ae-6ccf400be12800d6d52be2c0c43f53d80a443033.tar.bz2
master-31e0f0ae-6ccf400be12800d6d52be2c0c43f53d80a443033.zip
fstools: split snapshot-tool into its own package
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'package/system')
-rw-r--r--package/system/fstools/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index b4e8ded35e..8b39342f4d 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -50,6 +50,13 @@ define Package/fstools/config
This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
endef
+define Package/snapshot-tool
+ SECTION:=base
+ CATEGORY:=Base system
+ TITLE:=rootfs snapshoting tool
+ DEPENDS:=+libubox
+endef
+
define Package/block-mount
SECTION:=base
CATEGORY:=Base system
@@ -60,12 +67,18 @@ endef
define Package/fstools/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset,snapshot_tool} $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset} $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libfstools.so $(1)/lib/
- $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
$(LN) jffs2reset $(1)/sbin/jffs2mark
endef
+define Package/snapshot-tool/install
+ $(INSTALL_DIR) $(1)/sbin
+
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/snapshot_tool $(1)/sbin/
+ $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
+endef
+
define Package/block-mount/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
@@ -88,4 +101,5 @@ define Build/InstallDev
endef
$(eval $(call BuildPackage,fstools))
+$(eval $(call BuildPackage,snapshot-tool))
$(eval $(call BuildPackage,block-mount))