summaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2016-05-02 18:50:40 +0000
committerJo-Philipp Wich <jo@mein.io>2016-05-10 10:43:12 +0200
commitcbdfae5c04e90c05dcb247ea5e3d3c49670f3a84 (patch)
tree6743432e6d16c0d056a5ebf98314ac80c7335314 /package/system
parentd4de9f72f31c4716f78fea8950261a3bdafdbccb (diff)
downloadmaster-31e0f0ae-cbdfae5c04e90c05dcb247ea5e3d3c49670f3a84.tar.gz
master-31e0f0ae-cbdfae5c04e90c05dcb247ea5e3d3c49670f3a84.tar.bz2
master-31e0f0ae-cbdfae5c04e90c05dcb247ea5e3d3c49670f3a84.zip
ubox: turn logd into a separate package
Currently system log is always included as a part of ubox. Add logd as a seperate package and add it to default packages list. Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> SVN-Revision: 49285
Diffstat (limited to 'package/system')
-rw-r--r--package/system/ubox/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index b32c794618..f9f1ac17f1 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -28,11 +28,17 @@ define Package/ubox
TITLE:=OpenWrt system helper toolbox
endef
+define Package/logd
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+libubox +libubus +libblobmsg-json +USE_GLIBC:librt
+ TITLE:=OpenWrt system log implementation
+endef
+
define Package/ubox/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/ $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{kmodloader,logd,logread,validate_data} $(1)/sbin/
- $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{kmodloader,validate_data} $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib
$(LN) ../../sbin/kmodloader $(1)/usr/sbin/rmmod
@@ -42,4 +48,12 @@ define Package/ubox/install
$(LN) ../../sbin/kmodloader $(1)/usr/sbin/modprobe
endef
+define Package/logd/install
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d/
+
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{logd,logread} $(1)/sbin/
+ $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+endef
+
$(eval $(call BuildPackage,ubox))
+$(eval $(call BuildPackage,logd))