summaryrefslogtreecommitdiffstats
path: root/package/system/ubox
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-18 19:22:38 +0000
committerJohn Crispin <john@openwrt.org>2014-03-18 19:22:38 +0000
commitca4078c11048fcc729b028dfdb1828268335c5af (patch)
tree51856de3e2fcb5fb5aa56efbcbe721b1dcf8b092 /package/system/ubox
parent4835ea949f23a71c8f293984e5dee627fe67b781 (diff)
downloadmaster-31e0f0ae-ca4078c11048fcc729b028dfdb1828268335c5af.tar.gz
master-31e0f0ae-ca4078c11048fcc729b028dfdb1828268335c5af.tar.bz2
master-31e0f0ae-ca4078c11048fcc729b028dfdb1828268335c5af.zip
ubox: update to latest git head
logread now shows the right time. Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 39951
Diffstat (limited to 'package/system/ubox')
-rw-r--r--package/system/ubox/Makefile4
-rw-r--r--package/system/ubox/files/log.init7
2 files changed, 7 insertions, 4 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 08da9d0dda..09bbc0933c 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2014-03-12
+PKG_VERSION:=2014-03-18
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c8d14b9b5d0fa3a3f99df386b67670e083c82095
+PKG_SOURCE_VERSION:=1015c3779f37a17c6a2512bfc817e56d3042a237
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
diff --git a/package/system/ubox/files/log.init b/package/system/ubox/files/log.init
index ca29fd882c..e11a74b572 100644
--- a/package/system/ubox/files/log.init
+++ b/package/system/ubox/files/log.init
@@ -24,14 +24,17 @@ validate_log_section()
validate_log_daemon()
{
uci_validate_section system system "${1}" \
- 'log_buffer_size:uinteger:16'
+ 'log_size:uinteger:0' \
+ 'log_buffer_size:uinteger:0'
return $?
}
start_service_daemon()
{
- local log_buffer_size
+ local log_buffer_size log_size
validate_log_daemon "${1}"
+ [ $log_buffer_size -eq 0 -a $log_size -gt 0 ] && log_buffer_size=$log_size
+ [ $log_buffer_size -eq 0 ] && log_buffer_size=16
procd_open_instance
procd_set_param command "/sbin/logd"
procd_append_param command -S "${log_buffer_size}"