summaryrefslogtreecommitdiffstats
path: root/package/system/rpcd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-09-09 14:35:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-09-09 14:35:15 +0000
commite6d015489bc4afc26bdc8e0bc57a54ee7b3b049a (patch)
tree421d6cca424156130a6884a267567563b55eba45 /package/system/rpcd
parent768e6750d77438bb461c5396f205df8b7f56de94 (diff)
downloadmaster-31e0f0ae-e6d015489bc4afc26bdc8e0bc57a54ee7b3b049a.tar.gz
master-31e0f0ae-e6d015489bc4afc26bdc8e0bc57a54ee7b3b049a.tar.bz2
master-31e0f0ae-e6d015489bc4afc26bdc8e0bc57a54ee7b3b049a.zip
rpcd: update to git head
- adds support for service triggering on config commit - adds uci transaction support - adds daemon reload support without loosing session data - exports headers for use by external plugins - drops LuCI2 in favor to an out of tree plugin SVN-Revision: 37921
Diffstat (limited to 'package/system/rpcd')
-rw-r--r--package/system/rpcd/Makefile10
-rwxr-xr-xpackage/system/rpcd/files/rpcd.init4
2 files changed, 11 insertions, 3 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 0decaa651f..e6bf3a9791 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd
-PKG_VERSION:=2013-09-02
+PKG_VERSION:=2013-09-09
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/rpcd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=11f37e28898b12bf53d8df6272fa28c48d79a96b
+PKG_SOURCE_VERSION:=22fbf13086653cba0c60d60ceb7baba2f33a034d
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
@@ -26,6 +26,11 @@ PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/include/rpcd $(1)/usr/include/
+endef
+
define Package/rpcd/default
SECTION:=utils
CATEGORY:=Base system
@@ -79,5 +84,4 @@ endef
$(eval $(call BuildPackage,rpcd))
$(eval $(call BuildPlugin,file,,Provides ubus calls for file and directory operations.))
-$(eval $(call BuildPlugin,luci2,,Provides LuCI2 specific backend calls.))
$(eval $(call BuildPlugin,iwinfo,+libiwinfo,Provides ubus calls for accessing iwinfo data.))
diff --git a/package/system/rpcd/files/rpcd.init b/package/system/rpcd/files/rpcd.init
index 2b8f04f848..2132f16fd3 100755
--- a/package/system/rpcd/files/rpcd.init
+++ b/package/system/rpcd/files/rpcd.init
@@ -12,3 +12,7 @@ start() {
stop() {
service_stop /sbin/rpcd
}
+
+reload() {
+ service_reload /sbin/rpcd
+}