summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-23 15:26:09 +0000
committerJohn Crispin <john@openwrt.org>2015-05-23 15:26:09 +0000
commit86b573fa31e0cad026f0d5e8838bbe96f671b023 (patch)
treee74614faba0f440890c20730ac1de87cd277e20b /package/system/procd/Makefile
parent230efe318f85fc1fc14c7f3743bc9b2def1e7f22 (diff)
downloadmaster-31e0f0ae-86b573fa31e0cad026f0d5e8838bbe96f671b023.tar.gz
master-31e0f0ae-86b573fa31e0cad026f0d5e8838bbe96f671b023.tar.bz2
master-31e0f0ae-86b573fa31e0cad026f0d5e8838bbe96f671b023.zip
procd: make the jail code also work on arm
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45719
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 758f0a4a1a..44a836c4aa 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2015-05-05
+PKG_VERSION:=2015-05-23
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a6afa72f192f6efe8374d0f0c77fb2a545225a92
+PKG_SOURCE_VERSION:=a771644fd3a3ac055ec0c62fbe434aed0df002fe
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -77,12 +77,12 @@ config PROCD_ZRAM_TMPFS
config PROCD_JAIL_SUPPORT
bool
default y
- depends on (mips || mipsel || i386 || x86_64) && PROCD_SECCOMP_SUPPORT
+ depends on (arm || armeb || mips || mipsel || i386 || x86_64) && PROCD_SECCOMP_SUPPORT
config PROCD_SECCOMP_SUPPORT
bool
default y
- depends on (mips || mipsel || i386 || x86_64) && !TARGET_uml && @KERNEL_SECCOMP
+ depends on (arm || armeb || mips || mipsel || i386 || x86_64) && !TARGET_uml && @KERNEL_SECCOMP
endmenu
endef