summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-02 11:13:28 +0000
committerJohn Crispin <john@openwrt.org>2014-12-02 11:13:28 +0000
commit43131d62a87830b6ecc92619c563062092dd2d0d (patch)
treec668e30e560f51e8b8271de07b55a90d85569a32 /package/system/procd/Makefile
parent417e67b6b1cf6c5ead6ac368a559ac69ae833f00 (diff)
downloadmaster-31e0f0ae-43131d62a87830b6ecc92619c563062092dd2d0d.tar.gz
master-31e0f0ae-43131d62a87830b6ecc92619c563062092dd2d0d.tar.bz2
master-31e0f0ae-43131d62a87830b6ecc92619c563062092dd2d0d.zip
procd: add support for zram compressed /tmp
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43489
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index cbd2949448..27af3af97b 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2014-11-19
+PKG_VERSION:=2014-12-02
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=02e1a4eac725aaae10c119ec2ec20d0da4a2c958
+PKG_SOURCE_VERSION:=e1a27d486c2374f46abd264f3fd6561815155ebd
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -32,7 +32,7 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt +libubox +libubus +NAND_SUPPORT:procd-nand +PROCD_ZRAM_TMPFS:kmod-zram +PROCD_ZRAM_TMPFS:e2fsprogs
TITLE:=OpenWrt system process manager
endef
@@ -51,13 +51,22 @@ config PROCD_SHOW_BOOT
bool
default n
prompt "Print the shutdown to the console as well as logging it to syslog"
+
+config PROCD_ZRAM_TMPFS
+ bool
+ default n
+ prompt "Mount /tmp using zram."
endmenu
endef
-PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT
+PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT PROCD_ZRAM_TMPFS
+
+ifeq ($(CONFIG_PROCD_SHOW_BOOT),y)
+ CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE=1
+endif
-ifeq ($(CONFIG_PACKAGE_PROCD_SHOW_BOOT),y)
- CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE
+ifeq ($(CONFIG_PROCD_ZRAM_TMPFS),y)
+ CMAKE_OPTIONS += -DZRAM_TMPFS=1
endif
define Package/procd/install