summaryrefslogtreecommitdiffstats
path: root/package/system/procd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-11-13 10:49:25 +0000
committerJohn Crispin <john@openwrt.org>2013-11-13 10:49:25 +0000
commit130d7de07ffec8d9b822180aa681e66f7fa8b569 (patch)
tree6b3fb9320531009e23f423b0b54e28c19fc23342 /package/system/procd/Makefile
parent5fa0e4fac09473301af995ac8150da0ada8b3082 (diff)
downloadmaster-31e0f0ae-130d7de07ffec8d9b822180aa681e66f7fa8b569.tar.gz
master-31e0f0ae-130d7de07ffec8d9b822180aa681e66f7fa8b569.tar.bz2
master-31e0f0ae-130d7de07ffec8d9b822180aa681e66f7fa8b569.zip
procd: update to latest git head
this includes the first wip version of the uci validation backend Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38786
Diffstat (limited to 'package/system/procd/Makefile')
-rw-r--r--package/system/procd/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index b2d3bf1584..b406417469 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -1,14 +1,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2013-11-08
+PKG_VERSION:=2013-11-13
PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=315f04d8b823adda96041c17f6672b7790376ccb
+PKG_SOURCE_VERSION:=f9d31edb8938341b9217ee4c14eb58111414eb97
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -30,13 +30,14 @@ define Package/procd
endef
define Package/procd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d
+ $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d $(1)/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread} $(1)/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/{procd,askfirst,udevtrigger,logread,validate_data} $(1)/sbin/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib/
$(INSTALL_BIN) ./files/reload_config $(1)/sbin/
$(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
$(INSTALL_DATA) ./files/hotplug*.json $(1)/etc/
- $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
+ $(INSTALL_DATA) ./files/procd.sh ./files/procd-validate.sh $(1)/lib/functions/
ln -s /sbin/procd $(1)/sbin/init
endef