summaryrefslogtreecommitdiffstats
path: root/package/system/opkg
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-14 16:56:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-09-14 16:56:40 +0000
commit6497406220fd1e8e71741f2bced80983d2d7bae2 (patch)
tree5fb2b92bd92bba2e4340df9e122f89899f5f13d2 /package/system/opkg
parent01fb448d56b4559970ed8c7f67ba1312caf806a5 (diff)
downloadmaster-31e0f0ae-6497406220fd1e8e71741f2bced80983d2d7bae2.tar.gz
master-31e0f0ae-6497406220fd1e8e71741f2bced80983d2d7bae2.tar.bz2
master-31e0f0ae-6497406220fd1e8e71741f2bced80983d2d7bae2.zip
opkg: expose lists_dir option as command line argument
Expose the "lists_dir" configuration file option as command line switch so that we can override it for the Image Builder environment. Also add a more standard PKG_MAINTAINER variable while touching the Makefile. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 46911
Diffstat (limited to 'package/system/opkg')
-rw-r--r--package/system/opkg/Makefile7
-rw-r--r--package/system/opkg/patches/250-add-lists-dir-switch.patch39
2 files changed, 43 insertions, 3 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 4da4d46837..7401893a8a 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/feeds.mk
PKG_NAME:=opkg
PKG_REV:=9c97d5ecd795709c8584e972bfdf3aee3a5b846d
PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -26,6 +26,8 @@ PKG_REMOVE_FILES = autogen.sh aclocal.m4
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES
PKG_BUILD_PARALLEL:=1
@@ -39,7 +41,6 @@ define Package/opkg/Default
SECTION:=base
CATEGORY:=Base system
TITLE:=opkg package manager
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
URL:=http://wiki.openmoko.org/wiki/Opkg
endef
diff --git a/package/system/opkg/patches/250-add-lists-dir-switch.patch b/package/system/opkg/patches/250-add-lists-dir-switch.patch
new file mode 100644
index 0000000000..d0d0707836
--- /dev/null
+++ b/package/system/opkg/patches/250-add-lists-dir-switch.patch
@@ -0,0 +1,39 @@
+--- a/src/opkg-cl.c
++++ b/src/opkg-cl.c
+@@ -101,6 +101,8 @@ static struct option long_options[] = {
+ {"test", 0, 0, ARGS_OPT_NOACTION},
+ {"tmp-dir", 1, 0, 't'},
+ {"tmp_dir", 1, 0, 't'},
++ {"lists-dir", 1, 0, 'l'},
++ {"lists_dir", 1, 0, 'l'},
+ {"verbosity", 2, 0, 'V'},
+ {"version", 0, 0, 'v'},
+ {0, 0, 0, 0}
+@@ -115,7 +117,7 @@ args_parse(int argc, char *argv[])
+ char *tuple, *targ;
+
+ while (1) {
+- c = getopt_long_only(argc, argv, "Ad:f:ino:p:t:vV::",
++ c = getopt_long_only(argc, argv, "Ad:f:ino:p:l:t:vV::",
+ long_options, &option_index);
+ if (c == -1)
+ break;
+@@ -139,6 +141,9 @@ args_parse(int argc, char *argv[])
+ case 't':
+ conf->tmp_dir = xstrdup(optarg);
+ break;
++ case 'l':
++ conf->lists_dir = xstrdup(optarg);
++ break;
+ case 'v':
+ printf("opkg version %s\n", VERSION);
+ exit(0);
+@@ -316,6 +321,8 @@ usage()
+ printf("\t automatically to satisfy dependencies\n");
+ printf("\t-t Specify tmp-dir.\n");
+ printf("\t--tmp-dir Specify tmp-dir.\n");
++ printf("\t-l Specify lists-dir.\n");
++ printf("\t--lists-dir Specify lists-dir.\n");
+
+ printf("\n");
+