summaryrefslogtreecommitdiffstats
path: root/package/system/opkg
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-28 09:47:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-28 09:47:37 +0000
commit3c5357d6efe1a8d603f0071ce64d6807a6ebdfb6 (patch)
tree287839d2c13fa7b1309c60e1feffa34adfe85cb4 /package/system/opkg
parent21e16964bf40bb89a759a8e250e29af63d1402cf (diff)
downloadmaster-31e0f0ae-3c5357d6efe1a8d603f0071ce64d6807a6ebdfb6.tar.gz
master-31e0f0ae-3c5357d6efe1a8d603f0071ce64d6807a6ebdfb6.tar.bz2
master-31e0f0ae-3c5357d6efe1a8d603f0071ce64d6807a6ebdfb6.zip
feeds: use common macro "FeedSourcesAppend" to populate opkg configurations
This introduces a common macro to assemble the correct url templates to avoid code duplication and have the feed config handling in a central place. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 45799
Diffstat (limited to 'package/system/opkg')
-rw-r--r--package/system/opkg/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 1b1f3f19e4..d313c442dd 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -115,18 +115,7 @@ define Package/opkg/Default/install
ifneq ($(CONFIG_SIGNED_PACKAGES),)
echo "option check_signature 1" >> $(1)/etc/opkg.conf
endif
- ifeq ($(CONFIG_PER_FEED_REPO),)
- echo "src/gz %n %U" >> $(1)/etc/opkg.conf
- else
- for d in base $(FEEDS_ENABLED); do \
- echo "src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
- done
- ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
- for d in $(FEEDS_DISABLED); do \
- echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
- done
- endif
- endif
+ $(call FeedSourcesAppend,$(1)/etc/opkg.conf)
$(VERSION_SED) $(1)/etc/opkg.conf
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg
endef