summaryrefslogtreecommitdiffstats
path: root/package/system/fstools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-15 10:37:14 +0000
committerJohn Crispin <john@openwrt.org>2014-12-15 10:37:14 +0000
commit40e2dbf9c64a694095ede4db8ef1bc84f210f3c8 (patch)
treefe45e72558b89180bff104d4bec4a81244e0b5ed /package/system/fstools
parentf8e83b105730dcde47c375caeef3d6d0030cc5b7 (diff)
downloadmaster-31e0f0ae-40e2dbf9c64a694095ede4db8ef1bc84f210f3c8.tar.gz
master-31e0f0ae-40e2dbf9c64a694095ede4db8ef1bc84f210f3c8.tar.bz2
master-31e0f0ae-40e2dbf9c64a694095ede4db8ef1bc84f210f3c8.zip
fstools: update to latest git HEAD
adds a few cleanups and extroot/ubi support Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43717
Diffstat (limited to 'package/system/fstools')
-rw-r--r--package/system/fstools/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index 2688f4973c..9e3dde7fd2 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fstools
-PKG_VERSION:=2014-12-01
+PKG_VERSION:=2014-12-15
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/fstools.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=e65232440111b8f6654218033431e5bdd20525c2
+PKG_SOURCE_VERSION:=83cf8896a598fb9fc58da0a9bb4f137695f78853
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
PKG_CHECK_FORMAT_SECURITY:=0
@@ -31,12 +31,24 @@ include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
define Package/fstools
SECTION:=base
CATEGORY:=Base system
DEPENDS:=+ubox +USE_EGLIBC:librt +NAND_SUPPORT:ubi-utils
TITLE:=OpenWrt filesystem tools
+ MENU:=1
+endef
+
+define Package/fstools/config
+ config FSTOOLS_UBIFS_EXTROOT
+ depends on PACKAGE_fstools
+ depends on NAND_SUPPORT
+ bool "Support extroot functionality with UBIFS"
+ default y
+ help
+ This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
endef
define Package/block-mount