summaryrefslogtreecommitdiffstats
path: root/package/system/fstools/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-03 00:07:43 +0000
committerNicolas Thill <nico@openwrt.org>2015-04-03 00:07:43 +0000
commitfe46689f104b5d0363f06a286a215fd98a3e6d72 (patch)
tree3b892153949b8626645974385eba9b6ad9693435 /package/system/fstools/Makefile
parent6a5a7db085fd88a8e1f64107ca65124d925e790f (diff)
downloadmaster-31e0f0ae-fe46689f104b5d0363f06a286a215fd98a3e6d72.tar.gz
master-31e0f0ae-fe46689f104b5d0363f06a286a215fd98a3e6d72.tar.bz2
master-31e0f0ae-fe46689f104b5d0363f06a286a215fd98a3e6d72.zip
packages: use $(LN) macro, make symlinks relative
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 45250
Diffstat (limited to 'package/system/fstools/Makefile')
-rw-r--r--package/system/fstools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index f32ac2e35f..c76576640b 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -64,7 +64,7 @@ define Package/fstools/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset,snapshot_tool} $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libfstools.so $(1)/lib/
$(INSTALL_BIN) ./files/snapshot $(1)/sbin/
- ln -s /sbin/jffs2reset $(1)/sbin/jffs2mark
+ $(LN) jffs2reset $(1)/sbin/jffs2mark
endef
define Package/block-mount/install
@@ -76,8 +76,8 @@ define Package/block-mount/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/
- ln -s /sbin/block $(1)/usr/sbin/swapon
- ln -s /sbin/block $(1)/usr/sbin/swapoff
+ $(LN) ../../sbin/block $(1)/usr/sbin/swapon
+ $(LN) ../../sbin/block $(1)/usr/sbin/swapoff
endef