summaryrefslogtreecommitdiffstats
path: root/package/switch/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/switch/Makefile
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadmaster-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/switch/Makefile')
-rw-r--r--package/switch/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index 07208bc30f..a0644abeb1 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -41,12 +41,12 @@ define Build/Compile
endef
define Package/kmod-switch/install
- install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
$(1)/lib/modules/$(LINUX_VERSION)
- install -m0755 -d $(1)/lib/network/
- install -m0755 ./files/switch.sh $(1)/lib/network/
- install -m0755 -d $(1)/etc/modules.d/
+ $(INSTALL_DIR) $(1)/lib/network/
+ $(INSTALL_BIN) ./files/switch.sh $(1)/lib/network/
+ $(INSTALL_DIR) $(1)/etc/modules.d/
printf 'switch-core\nswitch-robo\nswitch-adm\n' > $(1)/etc/modules.d/20-switch
endef