summaryrefslogtreecommitdiffstats
path: root/package/switch/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:43:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:43:41 +0000
commit543d870e824730d0a85e4c999d9c21f58f0737b1 (patch)
tree2517eb31b9594e52382ec5397bbbf41c28c970f3 /package/switch/Makefile
parent08e4d51c29ea57920f6e5f7906b19b19e1c71a50 (diff)
downloadmaster-31e0f0ae-543d870e824730d0a85e4c999d9c21f58f0737b1.tar.gz
master-31e0f0ae-543d870e824730d0a85e4c999d9c21f58f0737b1.tar.bz2
master-31e0f0ae-543d870e824730d0a85e4c999d9c21f58f0737b1.zip
remove linux 2.4 support from several packages
SVN-Revision: 21954
Diffstat (limited to 'package/switch/Makefile')
-rw-r--r--package/switch/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index 74e42e6d93..7570f56d3d 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -15,7 +15,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/switch
SUBMENU:=Other modules
- DEPENDS:=@TARGET_brcm_2_4||TARGET_brcm47xx||TARGET_brcm63xx
+ DEPENDS:=@TARGET_brcm47xx||TARGET_brcm63xx
TITLE:=Switch drivers
FILES:= \
$(PKG_BUILD_DIR)/switch-core.$(LINUX_KMOD_SUFFIX) \
@@ -33,15 +33,10 @@ define Build/Prepare
$(CP) ./src/* $(PKG_BUILD_DIR)/
endef
-ifeq ($(BOARD),brcm-2.4)
- BUILDFLAGS := -DBROADCOM -DBCMDRIVER -I$(LINUX_DIR)/arch/mips/bcm947xx/include
-else
- ifeq ($(BOARD),brcm47xx)
+ifeq ($(BOARD),brcm47xx)
BUILDFLAGS := -DBROADCOM
- endif
endif
-
define Build/Compile
$(MAKE) -C "$(LINUX_DIR)" \
CROSS_COMPILE="$(TARGET_CROSS)" \