summaryrefslogtreecommitdiffstats
path: root/package/swconfig
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-10-03 23:39:31 +0000
committerJonas Gorski <jogo@openwrt.org>2011-10-03 23:39:31 +0000
commit936320f1f9efcb65cfb418b14507a5942f726cf7 (patch)
treed037824553602572fd43a860e278569c555dafe9 /package/swconfig
parent5171edd8d5f2607511ba2a86cf110686e10a8ad8 (diff)
downloadmaster-31e0f0ae-936320f1f9efcb65cfb418b14507a5942f726cf7.tar.gz
master-31e0f0ae-936320f1f9efcb65cfb418b14507a5942f726cf7.tar.bz2
master-31e0f0ae-936320f1f9efcb65cfb418b14507a5942f726cf7.zip
swconfig: fix vlan/port configs being applied to all switches
Check devn instead of dev (which will never be null at this point). SVN-Revision: 28362
Diffstat (limited to 'package/swconfig')
-rw-r--r--package/swconfig/Makefile2
-rw-r--r--package/swconfig/src/uci.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/swconfig/Makefile b/package/swconfig/Makefile
index 91939bb73f..099058e5f0 100644
--- a/package/swconfig/Makefile
+++ b/package/swconfig/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=swconfig
-PKG_RELEASE:=9
+PKG_RELEASE:=10
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk
diff --git a/package/swconfig/src/uci.c b/package/swconfig/src/uci.c
index 1de689ce6e..893e3d1dd8 100644
--- a/package/swconfig/src/uci.c
+++ b/package/swconfig/src/uci.c
@@ -183,7 +183,7 @@ found:
port = o->v.string;
}
}
- if (!dev || !port || !port[0])
+ if (!devn || !port || !port[0])
continue;
port_n = strtoul(port, &port_err, 0);
@@ -208,7 +208,7 @@ found:
vlan = o->v.string;
}
}
- if (!dev || !vlan || !vlan[0])
+ if (!devn || !vlan || !vlan[0])
continue;
vlan_n = strtoul(vlan, &vlan_err, 0);