summaryrefslogtreecommitdiffstats
path: root/package/rt61/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-30 02:41:27 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-30 02:41:27 +0000
commit8d42c41adaaa48483a4b16941563fe15516fc716 (patch)
tree1ac7423e5e4cf3c432f2296f75e51c6011cd61cb /package/rt61/Makefile
parent1d1acc0760d729c0b10938594ce68fda461b59a5 (diff)
downloadmaster-31e0f0ae-8d42c41adaaa48483a4b16941563fe15516fc716.tar.gz
master-31e0f0ae-8d42c41adaaa48483a4b16941563fe15516fc716.tar.bz2
master-31e0f0ae-8d42c41adaaa48483a4b16941563fe15516fc716.zip
Make rt61 become a real kernel package
SVN-Revision: 5931
Diffstat (limited to 'package/rt61/Makefile')
-rw-r--r--package/rt61/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/package/rt61/Makefile b/package/rt61/Makefile
index c7554d2d65..6147ac9113 100644
--- a/package/rt61/Makefile
+++ b/package/rt61/Makefile
@@ -21,13 +21,17 @@ PKG_CAT:=zcat
include $(INCLUDE_DIR)/package.mk
-define Package/kmod-rt61
- SECTION:=kernel
- CATEGORY:=Kernel drivers
- DEPENDS:=@LINUX_2_6_RDC
- TITLE:=Driver for Ralink RT61xx based boards
+define KernelPackage/rt61
+ SUBMENU:=Wireless Drivers
+ TITLE:=Driver for ralink MiMo pci chipsets
+ DEPENDS:=@USB_SUPPORT +wireless-tools
+ DESCRIPTION:=\
+ This package contains a driver for ralink rt61xx pci chipsets.
URL:=http://rt2x00.serialmonkey.com/
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ FILES:= \
+ $(PKG_BUILD_DIR)/Module/rt61.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,rt61)
endef
define Build/Compile
@@ -40,12 +44,4 @@ define Build/Compile
modules
endef
-define Package/kmod-rt61/install
- mkdir -p $(1)/etc/modules.d
- $(INSTALL_DATA) ./files/rt61.modules $(1)/etc/modules.d/10-ralink
- $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
- $(CP) $(PKG_BUILD_DIR)/Module/rt61.$(LINUX_KMOD_SUFFIX) \
- $(1)/lib/modules/$(LINUX_VERSION)/
-endef
-
-$(eval $(call BuildPackage,kmod-rt61))
+$(eval $(call KernelPackage,rt61))