summaryrefslogtreecommitdiffstats
path: root/package/rbcfg/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-06-29 09:40:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-06-29 09:40:54 +0000
commit43938e8eb9b839af842835819b0ef869a0f09ae2 (patch)
treeb93085534d661612e9d6d5f8fbf892c688df491c /package/rbcfg/Makefile
parentd98476c6bd9693fe39a090e17b3ef2679a39c363 (diff)
downloadmaster-31e0f0ae-43938e8eb9b839af842835819b0ef869a0f09ae2.tar.gz
master-31e0f0ae-43938e8eb9b839af842835819b0ef869a0f09ae2.tar.bz2
master-31e0f0ae-43938e8eb9b839af842835819b0ef869a0f09ae2.zip
package/rbcfg: new tool for modifying boot configuration on the RB4xx boards
SVN-Revision: 27315
Diffstat (limited to 'package/rbcfg/Makefile')
-rw-r--r--package/rbcfg/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/rbcfg/Makefile b/package/rbcfg/Makefile
new file mode 100644
index 0000000000..51fefd5942
--- /dev/null
+++ b/package/rbcfg/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rbcfg
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/rbcfg
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=RouterBOOT configuration tool
+ DEPENDS:=@TARGET_ar71xx
+endef
+
+define Package/rbcfg/description
+ This package contains an utility to manipulate RouterBOOT configuration on the
+ MikroTIK RB-4XX devices.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall" \
+ LDFLAGS="$(TARGET_LDFLAGS)"
+endef
+
+define Package/rbcfg/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/rbcfg $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,rbcfg))