summaryrefslogtreecommitdiffstats
path: root/package/qos-scripts/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-04-12 20:33:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-04-12 20:33:11 +0000
commit9646ca6c6e51a7a3656e2517b606fc5ebfca34b7 (patch)
tree5afa9339d1a075a10ef7a33e67945bc80ba255e3 /package/qos-scripts/Makefile
parentb32797cc551041fe37a8a04b48f014369d5f7cc1 (diff)
downloadmaster-31e0f0ae-9646ca6c6e51a7a3656e2517b606fc5ebfca34b7.tar.gz
master-31e0f0ae-9646ca6c6e51a7a3656e2517b606fc5ebfca34b7.tar.bz2
master-31e0f0ae-9646ca6c6e51a7a3656e2517b606fc5ebfca34b7.zip
This patch updates qos-scripts to support fair traffic sharing using the SFQ with external classifiers method. It also corrects a bug in the unsupported ESFQ method already used by qos-scripts. (ESFQ: http://fatooh.org/esfq-2.6/ only updated to 2.6.24, it was switched to an SFQ patch after that and not updated since 2008)
A class can be forced to use SFQ, and an external classifier added like this: config class "Normal" option avgrate 10 option priority 30 option packetdelay 100 option limitrate 94 # option qdisc "sfq perturb 2" config class "Normal_up" # option filter "protocol all flow hash keys src divisor 1024" config class "Normal_down" # option filter "protocol all flow hash keys dst divisor 1024" Using these options, the user needs to load cls_flow before qos-scripts starts. I've got more information here: http://oneitguy.com/blogs/netprince/fair-traffic-sharing-esfq-broken-switching-sfqexternal-classifiers This has been tested on r23914. Signed-off-by: Ben Pfountz <netprince<>vt_edu> SVN-Revision: 26622
Diffstat (limited to 'package/qos-scripts/Makefile')
-rw-r--r--package/qos-scripts/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/qos-scripts/Makefile b/package/qos-scripts/Makefile
index 21607a2d74..d76dbba854 100644
--- a/package/qos-scripts/Makefile
+++ b/package/qos-scripts/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
PKG_VERSION:=1.2.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)