summaryrefslogtreecommitdiffstats
path: root/package/qc-usb
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-16 16:39:18 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-16 16:39:18 +0000
commitcd2cccd2ff1b994882d1e93c8692a98ceb53002e (patch)
treed70db9e54376b29c15afbb2aa0f594de10f6655a /package/qc-usb
parent16de5a873eee8c89ea024b275de65870fc4b032e (diff)
downloadmaster-31e0f0ae-cd2cccd2ff1b994882d1e93c8692a98ceb53002e.tar.gz
master-31e0f0ae-cd2cccd2ff1b994882d1e93c8692a98ceb53002e.tar.bz2
master-31e0f0ae-cd2cccd2ff1b994882d1e93c8692a98ceb53002e.zip
various changes for kernel video support: * move kernel video related modules to a separate "Video Support" submenu and video.mk file * rename kmod-videodev to kmod-video-core * prefix all video modules with kmod-video- * add missing dependencies on USB support * rename kmod-usb-qc to kmod-video-quickcam
SVN-Revision: 8806
Diffstat (limited to 'package/qc-usb')
-rw-r--r--package/qc-usb/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/package/qc-usb/Makefile b/package/qc-usb/Makefile
index 3ae5061322..a1a16b34cb 100644
--- a/package/qc-usb/Makefile
+++ b/package/qc-usb/Makefile
@@ -4,7 +4,7 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-# $Id: $
+# $Id$
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
@@ -35,21 +35,21 @@ define Package/qc-usb-utils/description
These programs are completely useless without a qc-usb-modules package.
endef
-define KernelPackage/usb-qc
+define KernelPackage/video-quickcam
$(call Package/qc-usb/Default)
- TITLE:=Support for USB QuickCam Express webcam
- SUBMENU:=USB Support
- DEPENDS:=@LINUX_2_6 @USB_SUPPORT kmod-usb-core +kmod-videodev
+ SUBMENU:=Video Support
+ TITLE:=USB QuickCam Express webcam support
+ DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core +kmod-video-core
FILES:=$(PKG_BUILD_DIR)/quickcam.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,90,quickcam)
endef
-define KernelPackage/usb-qc/description
+define KernelPackage/video-quickcam/description
Kernel support for Logitech's QuickCam Express webcam and other webcams
with similar chipsets.
endef
-ifneq ($(CONFIG_PACKAGE_kmod-usb-qc),)
+ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
define Build/Compile/kmod
$(MAKE) -C $(LINUX_DIR) \
PATH="$(TARGET_PATH)" \
@@ -66,7 +66,6 @@ endif
define Build/Compile
$(call Build/Compile/kmod)
-
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS)" \
qcset
@@ -78,4 +77,4 @@ define Package/qc-usb-utils/install
endef
$(eval $(call BuildPackage,qc-usb-utils))
-$(eval $(call KernelPackage,usb-qc))
+$(eval $(call KernelPackage,video-quickcam))