summaryrefslogtreecommitdiffstats
path: root/package/qc-usb
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-20 09:49:13 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-20 09:49:13 +0000
commit6b8489761c8cef3c4573018971d9f64b210cfb75 (patch)
tree69ff98f8f9e85c3ec5900b6e6c85abc8b333f933 /package/qc-usb
parenteb8375839a7468afae9b7ef444d4f01329c28393 (diff)
downloadmaster-31e0f0ae-6b8489761c8cef3c4573018971d9f64b210cfb75.tar.gz
master-31e0f0ae-6b8489761c8cef3c4573018971d9f64b210cfb75.tar.bz2
master-31e0f0ae-6b8489761c8cef3c4573018971d9f64b210cfb75.zip
build the kmod-video-quickcam module only if it was selected
SVN-Revision: 10881
Diffstat (limited to 'package/qc-usb')
-rw-r--r--package/qc-usb/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/qc-usb/Makefile b/package/qc-usb/Makefile
index 1d57ccb664..8fd666809a 100644
--- a/package/qc-usb/Makefile
+++ b/package/qc-usb/Makefile
@@ -58,7 +58,8 @@ ifeq ($(KERNEL),2.4)
endif
endif
-define Build/Compile
+ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
+ define Build/Compile/kmod
$(MAKE) -C $(PKG_BUILD_DIR) \
LINUX_DIR="$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \
@@ -67,11 +68,20 @@ define Build/Compile
LD="$(TARGET_CC) -nodefaultlibs -nostartfiles" \
USER_OPT="$(KERNEL_C_OPTS)" \
quickcam.$(LINUX_KMOD_SUFFIX)
+ endef
+endif
+
+define Build/Compile/user
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS)" \
qcset
endef
+define Build/Compile
+ $(call Build/Compile/kmod)
+ $(call Build/Compile/user)
+endef
+
define Package/qc-usb-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/qcset $(1)/usr/bin/