summaryrefslogtreecommitdiffstats
path: root/package/procd
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-03 10:01:10 +0000
committerJohn Crispin <john@openwrt.org>2013-04-03 10:01:10 +0000
commit9b3b0473aed09239c5bca27616e0a455432820e6 (patch)
treed47db43ff0ab1c97158a480c0a1743fd61e84bcd /package/procd
parentd9bb7ff7a5da097f34f13912d6bb599a8fe7848d (diff)
downloadmaster-31e0f0ae-9b3b0473aed09239c5bca27616e0a455432820e6.tar.gz
master-31e0f0ae-9b3b0473aed09239c5bca27616e0a455432820e6.tar.bz2
master-31e0f0ae-9b3b0473aed09239c5bca27616e0a455432820e6.zip
fix eglibc compile
add librt dependency/link flag to procd when using eglibc thanks to jow for the help Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr> SVN-Revision: 36188
Diffstat (limited to 'package/procd')
-rw-r--r--package/procd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/procd/Makefile b/package/procd/Makefile
index 762fb5f18f..53c102a7cb 100644
--- a/package/procd/Makefile
+++ b/package/procd/Makefile
@@ -21,10 +21,12 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script
+ DEPENDS:=+ubusd +ubus +libjson-script +USE_EGLIBC:librt
TITLE:=OpenWrt system process manager
endef