summaryrefslogtreecommitdiffstats
path: root/package/pptp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/pptp
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadmaster-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/pptp')
-rw-r--r--package/pptp/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/pptp/Makefile b/package/pptp/Makefile
index bb0710419b..081ff4e52a 100644
--- a/package/pptp/Makefile
+++ b/package/pptp/Makefile
@@ -31,12 +31,12 @@ define Package/pptp
endef
define Package/pptp/install
- install -d -m0755 $(1)/usr/sbin
- install -m0755 $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
- install -d -m0755 $(1)/etc/ppp
- install -m0644 ./files/options.pptp $(1)/etc/ppp/
- install -d -m0755 $(1)/lib/network
- install -m0755 ./files/pptp.sh $(1)/lib/network/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/pptp $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/etc/ppp
+ $(INSTALL_DATA) ./files/options.pptp $(1)/etc/ppp/
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_BIN) ./files/pptp.sh $(1)/lib/network/
endef
$(eval $(call BuildPackage,pptp))