summaryrefslogtreecommitdiffstats
path: root/package/platform/lantiq/ltq-ifxos/patches/100-compat.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-15 02:00:26 +0000
committerJohn Crispin <john@openwrt.org>2012-12-15 02:00:26 +0000
commitc2738a9559f434db5d28282051741e24298344af (patch)
tree99aab7406990250ab6e9480ab0861017a1749e90 /package/platform/lantiq/ltq-ifxos/patches/100-compat.patch
parent2c33df03761f366193eeb2c3ffd28dfea475de41 (diff)
downloadmaster-31e0f0ae-c2738a9559f434db5d28282051741e24298344af.tar.gz
master-31e0f0ae-c2738a9559f434db5d28282051741e24298344af.tar.bz2
master-31e0f0ae-c2738a9559f434db5d28282051741e24298344af.zip
move ltq-ifxos
SVN-Revision: 34692
Diffstat (limited to 'package/platform/lantiq/ltq-ifxos/patches/100-compat.patch')
-rw-r--r--package/platform/lantiq/ltq-ifxos/patches/100-compat.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/platform/lantiq/ltq-ifxos/patches/100-compat.patch b/package/platform/lantiq/ltq-ifxos/patches/100-compat.patch
new file mode 100644
index 0000000000..02f2da728e
--- /dev/null
+++ b/package/platform/lantiq/ltq-ifxos/patches/100-compat.patch
@@ -0,0 +1,21 @@
+--- a/configure.in
++++ b/configure.in
+@@ -64,7 +64,7 @@ dnl Set kernel build path
+ AC_ARG_ENABLE(kernelbuild,
+ AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path (only for kernel 2.6.x)),
+ [
+- if test -e $enableval/include/linux/autoconf.h; then
++ if test -e $enableval/include/linux/autoconf.h -o -e $enableval/include/generated/autoconf.h; then
+ AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
+ else
+ AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
+--- a/src/linux/ifxos_linux_thread_drv.c
++++ b/src/linux/ifxos_linux_thread_drv.c
+@@ -34,7 +34,6 @@
+ #include <linux/sched.h>
+ #include <linux/version.h>
+ #include <linux/completion.h>
+-#include <linux/smp_lock.h>
+ #include <linux/signal.h>
+
+