summaryrefslogtreecommitdiffstats
path: root/package/owipcalc/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-07-19 16:17:23 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-07-19 16:17:23 +0000
commit542eed01433f0677978fdf245a845a39b55b5183 (patch)
tree6d739e30d303c527cd20f65793de643075b8f929 /package/owipcalc/Makefile
parent4d844e10ab2b5fc6808adde9f9a43d09b5143eea (diff)
downloadmaster-31e0f0ae-542eed01433f0677978fdf245a845a39b55b5183.tar.gz
master-31e0f0ae-542eed01433f0677978fdf245a845a39b55b5183.tar.bz2
master-31e0f0ae-542eed01433f0677978fdf245a845a39b55b5183.zip
add owipcalc - a small ipv4 & ipv6 calculation utility
SVN-Revision: 32778
Diffstat (limited to 'package/owipcalc/Makefile')
-rw-r--r--package/owipcalc/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/owipcalc/Makefile b/package/owipcalc/Makefile
new file mode 100644
index 0000000000..9ff9b24c2c
--- /dev/null
+++ b/package/owipcalc/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2012 Jo-Philipp Wich <jow@openwrt.org>
+#
+# This is free software, licensed under the Apache 2 license.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=owipcalc
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+
+define Package/owipcalc
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Simple IPv4/IPv6 address calculator
+ MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+endef
+
+define Package/owipcalc/description
+ The owipcalc utility supports a number of calculations and tests to work
+ with ip-address ranges, this is useful for scripts that e.g. need to
+ partition ipv6-prefixes into small subnets or to calculate address ranges
+ for dhcp pools.
+endef
+
+
+define Build/Prepare
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+ $(TARGET_CC) $(TARGET_CFLAGS) \
+ -o $(PKG_BUILD_DIR)/owipcalc $(PKG_BUILD_DIR)/owipcalc.c
+endef
+
+
+define Package/owipcalc/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/owipcalc $(1)/usr/bin/owipcalc
+endef
+
+$(eval $(call BuildPackage,owipcalc))