summaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-06 02:12:14 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-06 02:12:14 +0000
commita836869b692db1da28f68ac30439d57b68255d9a (patch)
tree94112aebba2722f2e365975eff00089623cd6e7e /package/opkg
parent097d38615bd44d91a6b1f12748cc4ce62bbd008c (diff)
downloadmaster-31e0f0ae-a836869b692db1da28f68ac30439d57b68255d9a.tar.gz
master-31e0f0ae-a836869b692db1da28f68ac30439d57b68255d9a.tar.bz2
master-31e0f0ae-a836869b692db1da28f68ac30439d57b68255d9a.zip
opkg: reintroduce host build, utilize fixed HOST_BUILD_DEPENDS and depend libtool/host
SVN-Revision: 22947
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index c18f8e7319..442f90cd1a 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -18,7 +18,9 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_FIXUP = libtool
+
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/opkg
SECTION:=base
@@ -79,4 +81,27 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/libopkg $(1)/usr/include/
endef
+
+HOST_BUILD_DEPENDS:=libtool/host
+
+HOST_CONFIGURE_ARGS+= \
+ --disable-curl \
+ --disable-gpg \
+ --with-opkgetcdir=/etc \
+ --with-opkglockfile=/tmp/opkg.lock
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
+ $(call Host/Configure/Default)
+endef
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
+endef
+
$(eval $(call BuildPackage,opkg))
+$(eval $(call HostBuild))