summaryrefslogtreecommitdiffstats
path: root/package/opkg
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-30 19:38:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-30 19:38:58 +0000
commit97c4a54db3b49eb1c513fa2919e8183b2a7039dc (patch)
tree9d5130d9b897f54c73a462d5d39a2ad98776e105 /package/opkg
parent8994dc436140e9e538fad9763c0076c24332649a (diff)
downloadmaster-31e0f0ae-97c4a54db3b49eb1c513fa2919e8183b2a7039dc.tar.gz
master-31e0f0ae-97c4a54db3b49eb1c513fa2919e8183b2a7039dc.tar.bz2
master-31e0f0ae-97c4a54db3b49eb1c513fa2919e8183b2a7039dc.zip
opkg: work around the same broken array overrun check in gcc 4.4 as in gcc 4.3
SVN-Revision: 15522
Diffstat (limited to 'package/opkg')
-rw-r--r--package/opkg/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index 8a06ec0726..8b1961985e 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -40,7 +40,7 @@ define Package/opkg/conffiles
/etc/opkg.conf
endef
-TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
+TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),-Wno-array-bounds)
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
EXTRA_LDFLAGS += $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib