summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/openssl
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadmaster-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 7bb31c8cb3..827c4415c0 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -115,18 +115,18 @@ define Build/UninstallDev
endef
define Package/libopenssl/install
- install -d -m0755 $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
chmod 0644 $(1)/usr/lib/*
endef
define Package/openssl-util/install
- install -d -m0755 $(1)/etc/ssl
+ $(INSTALL_DIR) $(1)/etc/ssl
$(CP) $(PKG_INSTALL_DIR)/etc/ssl/openssl.cnf $(1)/etc/ssl/
- install -d -m0755 $(1)/etc/ssl/certs
- install -d -m0755 $(1)/etc/ssl/private
+ $(INSTALL_DIR) $(1)/etc/ssl/certs
+ $(INSTALL_DIR) $(1)/etc/ssl/private
chmod 0700 $(1)/etc/ssl/private
- install -d -m0755 $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/openssl $(1)/usr/bin/
endef