summaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:45:11 +0000
commit969ac7459ee6f948ea1c8804cc38d659e0c4a9d1 (patch)
tree7fa927cde9937adeae52d231c1266c7432dc9316 /package/openssl/Makefile
parent800ef0f56ca5971811267b5639c7895c2d569491 (diff)
downloadmaster-31e0f0ae-969ac7459ee6f948ea1c8804cc38d659e0c4a9d1.tar.gz
master-31e0f0ae-969ac7459ee6f948ea1c8804cc38d659e0c4a9d1.tar.bz2
master-31e0f0ae-969ac7459ee6f948ea1c8804cc38d659e0c4a9d1.zip
add $(STAGING_DIR) as argument to the InstallDev template and update packages accordingly - this way we can reuse InstallDev to automatically generate UninstallDev or create -dev packages
SVN-Revision: 9052
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 36b5b24e27..270fe5e755 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -109,21 +109,21 @@ define Build/Compile
endef
define Build/InstallDev
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
- mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
- $(SED) 's,^includedir=.*,includedir=$(STAGING_DIR)/usr/include,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
- $(SED) 's,^libdir=.*,libdir=$(STAGING_DIR)/usr/lib,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
- $(SED) 's,$(TARGET_LDFLAGS),,g' $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ mkdir -p $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
+ mkdir -p $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
+ mkdir -p $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
+ $(SED) 's,^includedir=.*,includedir=$(1)/usr/include,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's,^libdir=.*,libdir=$(1)/usr/lib,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Build/UninstallDev
- rm -rf $(STAGING_DIR)/usr/include/openssl \
- $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} \
- $(STAGING_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ rm -rf $(1)/usr/include/openssl \
+ $(1)/usr/lib/lib{crypto,ssl}.{a,so*} \
+ $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Package/libopenssl/install