summaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-06-29 20:48:58 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-06-29 20:48:58 +0000
commit115aced5c77eb36252faf4fa6a96cd956f0a0c58 (patch)
treeece19fc7415def8ea8b8a53aeb74d2fc188bec60 /package/openssl/Makefile
parentd9259b25bfc89e408b1c8bd17b028f6c08840d16 (diff)
downloadmaster-31e0f0ae-115aced5c77eb36252faf4fa6a96cd956f0a0c58.tar.gz
master-31e0f0ae-115aced5c77eb36252faf4fa6a96cd956f0a0c58.tar.bz2
master-31e0f0ae-115aced5c77eb36252faf4fa6a96cd956f0a0c58.zip
openssl: fix bad chmod in install section (#5433)
SVN-Revision: 16624
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 3483c609d2..e6788172d1 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -130,8 +130,8 @@ endef
define Package/libopenssl/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.so.* $(1)/usr/lib/
- chmod 0644 $(1)/usr/lib/*
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libcrypto.so.* $(1)/usr/lib/
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libssl.so.* $(1)/usr/lib/
endef
define Package/openssl-util/install