summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-29 15:09:50 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-30 10:51:21 +0200
commit98206cb9c62a86f3e72b74a71e9ed836bac1fc71 (patch)
tree4d8acc8419d66f1c8ad157d915dc312ea9c9a0ba /package/network
parentb0dcb6bfed97cf8e63ad03ca76b49cad45dbffea (diff)
downloadmaster-31e0f0ae-98206cb9c62a86f3e72b74a71e9ed836bac1fc71.tar.gz
master-31e0f0ae-98206cb9c62a86f3e72b74a71e9ed836bac1fc71.tar.bz2
master-31e0f0ae-98206cb9c62a86f3e72b74a71e9ed836bac1fc71.zip
iperf: add -lm to fix build with newer glibc
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iperf/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/iperf/Makefile b/package/network/utils/iperf/Makefile
index 2bd19173c0..c47830c5cd 100644
--- a/package/network/utils/iperf/Makefile
+++ b/package/network/utils/iperf/Makefile
@@ -41,7 +41,7 @@ TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += --disable-multicast
CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
-CONFIGURE_VARS += LIBS="-lpthread"
+CONFIGURE_VARS += LIBS="-lpthread -lm"
define Package/iperf/install
$(INSTALL_DIR) $(1)/usr/bin