summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-03-13 18:11:25 +0000
committerJohn Crispin <john@openwrt.org>2013-03-13 18:11:25 +0000
commitfce3deddff594be4a9d71f53e5ed6812033c2dd0 (patch)
tree131e58c02aeed3d293525f60267018a99b902059 /package/network
parentf43b7934d2850c2f545736253a0f8cbe4915fdff (diff)
downloadmaster-31e0f0ae-fce3deddff594be4a9d71f53e5ed6812033c2dd0.tar.gz
master-31e0f0ae-fce3deddff594be4a9d71f53e5ed6812033c2dd0.tar.bz2
master-31e0f0ae-fce3deddff594be4a9d71f53e5ed6812033c2dd0.zip
use new button scheme
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36004
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile5
-rw-r--r--package/network/services/hostapd/files/wps-hotplug.sh2
2 files changed, 7 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 80845bf06b..16db2d8e23 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -303,6 +303,11 @@ ifneq ($(LOCAL_TYPE),supplicant)
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
$(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
+ $(if $(CONFIG_PROCD_INIT),
+ $(INSTALL_DIR) $(1)/etc/rc.button/
+ $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
+ $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
+ )
endef
endif
diff --git a/package/network/services/hostapd/files/wps-hotplug.sh b/package/network/services/hostapd/files/wps-hotplug.sh
index b5376cc55b..ffd3cf929b 100644
--- a/package/network/services/hostapd/files/wps-hotplug.sh
+++ b/package/network/services/hostapd/files/wps-hotplug.sh
@@ -1,3 +1,5 @@
+#!/bin/sh
+
if [ "$ACTION" = "pressed" -a "$BUTTON" = "wps" ]; then
for dir in /var/run/hostapd-*; do
[ -d "$dir" ] || continue