summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
committerNicolas Thill <nico@openwrt.org>2014-11-06 19:35:34 +0000
commitf4417f7ad8f2da7d99c48eead14b0a2e8ad0f387 (patch)
treea0e28ec68139151407b3a76169cba65a52840029 /package/network
parentbd92e9806b35a0d9f6d8351eb274d2cdfcc142b9 (diff)
downloadmaster-31e0f0ae-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.gz
master-31e0f0ae-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.tar.bz2
master-31e0f0ae-f4417f7ad8f2da7d99c48eead14b0a2e8ad0f387.zip
package/*: replace occurences of 'ln -sf' to '$(LN)'
Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 43205
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dropbear/Makefile10
-rw-r--r--package/network/services/hostapd/Makefile4
-rw-r--r--package/network/services/ppp/Makefile2
-rw-r--r--package/network/services/samba36/Makefile8
-rw-r--r--package/network/utils/curl/Makefile2
-rw-r--r--package/network/utils/wireless-tools/Makefile8
6 files changed, 17 insertions, 17 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index d805f00cd3..12a836be37 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -107,10 +107,10 @@ define Package/dropbear/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dropbearmulti $(1)/usr/sbin/dropbear
$(INSTALL_DIR) $(1)/usr/bin
- ln -sf ../sbin/dropbear $(1)/usr/bin/scp
- ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
- ln -sf ../sbin/dropbear $(1)/usr/bin/dbclient
- ln -sf ../sbin/dropbear $(1)/usr/bin/dropbearkey
+ $(LN) ../sbin/dropbear $(1)/usr/bin/scp
+ $(LN) ../sbin/dropbear $(1)/usr/bin/ssh
+ $(LN) ../sbin/dropbear $(1)/usr/bin/dbclient
+ $(LN) ../sbin/dropbear $(1)/usr/bin/dropbearkey
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
$(INSTALL_DIR) $(1)/etc/init.d
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d698c050a3..d8b3498b11 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -372,8 +372,8 @@ define Package/wpad/install
$(call Install/hostapd,$(1))
$(call Install/supplicant,$(1))
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wpad $(1)/usr/sbin/
- ln -sf wpad $(1)/usr/sbin/hostapd
- ln -sf wpad $(1)/usr/sbin/wpa_supplicant
+ $(LN) wpad $(1)/usr/sbin/hostapd
+ $(LN) wpad $(1)/usr/sbin/wpa_supplicant
endef
Package/wpad-mini/install = $(Package/wpad/install)
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 33b71ffe82..efb0a76fbb 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -191,7 +191,7 @@ define Package/ppp/install
$(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
$(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
- ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
+ $(LN) /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
$(INSTALL_DIR) $(1)/lib/netifd/proto
$(INSTALL_BIN) ./files/ppp.sh $(1)/lib/netifd/proto/
$(INSTALL_BIN) ./files/lib/netifd/ppp-up $(1)/lib/netifd/
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index 4dff34b3c9..16838be4df 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -135,9 +135,9 @@ define Package/samba36-server/install
$(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_BIN)/samba_multicall $(1)/usr/sbin
- ln -sf samba_multicall $(1)/usr/sbin/smbd
- ln -sf samba_multicall $(1)/usr/sbin/nmbd
- ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
+ $(LN) samba_multicall $(1)/usr/sbin/smbd
+ $(LN) samba_multicall $(1)/usr/sbin/nmbd
+ $(LN) samba_multicall $(1)/usr/sbin/smbpasswd
endef
define Package/samba36-client/install
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index a77fcc89a7..f78fa9e9a2 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -145,7 +145,7 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
$(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
[ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc || true
- ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
+ $(LN) $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
endef
define Package/curl/install
diff --git a/package/network/utils/wireless-tools/Makefile b/package/network/utils/wireless-tools/Makefile
index 64b6f9fc7a..67986baaa1 100644
--- a/package/network/utils/wireless-tools/Makefile
+++ b/package/network/utils/wireless-tools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -73,14 +73,14 @@ define Build/InstallDev
$(CP) $(PKG_BUILD_DIR)/{iwlib,wireless}.h $(1)/usr/include/
mkdir -p $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/libiw.so* $(1)/usr/lib/
- ln -sf libiw.so.$(PKG_VERSION) $(1)/usr/lib/libiw.so
+ $(LN) libiw.so.$(PKG_VERSION) $(1)/usr/lib/libiw.so
endef
define Package/wireless-tools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iwconfig $(1)/usr/sbin/
- ln -sf iwconfig $(1)/usr/sbin/iwlist
- ln -sf iwconfig $(1)/usr/sbin/iwpriv
+ $(LN) iwconfig $(1)/usr/sbin/iwlist
+ $(LN) iwconfig $(1)/usr/sbin/iwpriv
endef
define Package/libiw/install