summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-18 11:42:43 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-18 11:42:43 +0000
commitc8e0c28c15677d010fc4cf11b53e36ba91fa4d96 (patch)
tree2b563b6347f15353c6d103106e03b7356a45d450 /package/network
parent494bc1d0264022e5fda842e0a7bbf516c5fc3041 (diff)
downloadmaster-31e0f0ae-c8e0c28c15677d010fc4cf11b53e36ba91fa4d96.tar.gz
master-31e0f0ae-c8e0c28c15677d010fc4cf11b53e36ba91fa4d96.tar.bz2
master-31e0f0ae-c8e0c28c15677d010fc4cf11b53e36ba91fa4d96.zip
iwinfo: make 'type' visible in wrapped iwinfo
There are several cases within 'luci' that attempt to access the interface 'type' from within the 'type' specific meta tables; however, 'type' is not currently available there. Replicate the common metadata in the 'type' specific meta tables. Signed-off-by: Nathan Hintz <nlhintz@hotmail.com> SVN-Revision: 38448
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iwinfo/Makefile2
-rw-r--r--package/network/utils/iwinfo/src/iwinfo_lua.c4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/iwinfo/Makefile b/package/network/utils/iwinfo/Makefile
index aa534112ed..9bebb7a619 100644
--- a/package/network/utils/iwinfo/Makefile
+++ b/package/network/utils/iwinfo/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiwinfo
-PKG_RELEASE:=46
+PKG_RELEASE:=47
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/network/utils/iwinfo/src/iwinfo_lua.c b/package/network/utils/iwinfo/src/iwinfo_lua.c
index fc4fd4a126..3f1f2061ca 100644
--- a/package/network/utils/iwinfo/src/iwinfo_lua.c
+++ b/package/network/utils/iwinfo/src/iwinfo_lua.c
@@ -862,6 +862,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#ifdef USE_WL
luaL_newmetatable(L, IWINFO_WL_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_wl);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");
@@ -870,6 +871,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#ifdef USE_MADWIFI
luaL_newmetatable(L, IWINFO_MADWIFI_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_madwifi);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");
@@ -878,6 +880,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#ifdef USE_NL80211
luaL_newmetatable(L, IWINFO_NL80211_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_nl80211);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");
@@ -885,6 +888,7 @@ LUALIB_API int luaopen_iwinfo(lua_State *L) {
#endif
luaL_newmetatable(L, IWINFO_WEXT_META);
+ luaL_register(L, NULL, R_common);
luaL_register(L, NULL, R_wext);
lua_pushvalue(L, -1);
lua_setfield(L, -2, "__index");