summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorHans Dedecker <hans.dedecker@technicolor.com>2016-06-29 14:29:48 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-30 00:42:46 +0200
commitc2bd4695211e78da3a7899f8ee386ff06c3501e8 (patch)
tree693e6d076860a60f17ed4b689f5964b96ff5d059 /package/network
parent95d9330d572836f9e7cbc3217b56cb3acaf6b361 (diff)
downloadmaster-31e0f0ae-c2bd4695211e78da3a7899f8ee386ff06c3501e8.tar.gz
master-31e0f0ae-c2bd4695211e78da3a7899f8ee386ff06c3501e8.tar.bz2
master-31e0f0ae-c2bd4695211e78da3a7899f8ee386ff06c3501e8.zip
dnsmasq: Add broken realtime clock build switch in full variant
By default dnsmasq uses the time function; which returns the time since Epoch; to retrieve the current time. On boards which have no realtime clock this can lead to side effects when the time is synced via ntp as the "time wrap" forces dhcp leases to be considered as expired. By enabling the broken realtime clock build switch dnsmasq uses the times utility which returns the number of clock tick. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [Jo-Philipp Wich: change symbol name, add sym to PKG_CONFIG_DEPENDS] Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dnsmasq/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index aed40b2972..3aff519e6b 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.76
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
@@ -26,7 +26,8 @@ PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_dhcpv6 \
CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_dnssec \
CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_auth \
CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_ipset \
- CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_conntrack
+ CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_conntrack \
+ CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_broken_rtc
include $(INCLUDE_DIR)/package.mk
@@ -99,6 +100,9 @@ define Package/dnsmasq-full/config
config PACKAGE_dnsmasq_full_conntrack
bool "Build with Conntrack support."
default y
+ config PACKAGE_dnsmasq_full_broken_rtc
+ bool "Build with HAVE_BROKEN_RTC."
+ default n
endif
endef
@@ -119,7 +123,8 @@ ifeq ($(BUILD_VARIANT),full)
$(if $(CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_dnssec),-DHAVE_DNSSEC) \
$(if $(CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_auth),,-DNO_AUTH) \
$(if $(CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_ipset),,-DNO_IPSET) \
- $(if $(CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_conntrack),-DHAVE_CONNTRACK,)
+ $(if $(CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_conntrack),-DHAVE_CONNTRACK,) \
+ $(if $(CONFIG_PACKAGE_dnsmasq_$(BUILD_VARIANT)_broken_rtc),-DHAVE_BROKEN_RTC)
COPTS += $(if $(CONFIG_LIBNETTLE_MINI),-DNO_GMP,)
else
COPTS += -DNO_AUTH -DNO_IPSET