summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-03-09 22:07:05 +0000
committerNicolas Thill <nico@openwrt.org>2015-03-09 22:07:05 +0000
commita7f198b12cdafaa515a59d323d627893b4337e16 (patch)
tree772c70bdd81c14b4526586b971dc3cd1a153dbf3 /package/network
parent28631b65c28ef6405fb07062b5294a9bfefd0ad5 (diff)
downloadmaster-31e0f0ae-a7f198b12cdafaa515a59d323d627893b4337e16.tar.gz
master-31e0f0ae-a7f198b12cdafaa515a59d323d627893b4337e16.tar.bz2
master-31e0f0ae-a7f198b12cdafaa515a59d323d627893b4337e16.zip
ebtables: revert "disable rpath" (closes: #19088)
This reverts commit 9340723d70bce9d905c3f53b2bf415963153b34d. Signed-off-by: Nicolas Thill <nico@openwrt.org> SVN-Revision: 44634
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/ebtables/Makefile2
-rw-r--r--package/network/utils/ebtables/patches/001-no_rpath.patch30
2 files changed, 1 insertions, 31 deletions
diff --git a/package/network/utils/ebtables/Makefile b/package/network/utils/ebtables/Makefile
index 214e247e74..4f6d7f5323 100644
--- a/package/network/utils/ebtables/Makefile
+++ b/package/network/utils/ebtables/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
PKG_VERSION:=2.0.10-4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ebtables
diff --git a/package/network/utils/ebtables/patches/001-no_rpath.patch b/package/network/utils/ebtables/patches/001-no_rpath.patch
deleted file mode 100644
index d4c13f620b..0000000000
--- a/package/network/utils/ebtables/patches/001-no_rpath.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -90,8 +90,7 @@ libebtc.so: $(OBJECTS2)
- $(CC) -shared $(LDFLAGS) -Wl,-soname,libebtc.so -o libebtc.so -lc $(OBJECTS2)
-
- ebtables: $(OBJECTS) ebtables-standalone.o libebtc.so
-- $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
-- -Wl,-rpath,$(LIBDIR)
-+ $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
-
- ebtablesu: ebtablesu.c
- $(CC) $(CFLAGS) $(PROGSPECSD) $< -o $@
-@@ -100,15 +99,13 @@ ebtablesd.o: ebtablesd.c include/ebtable
- $(CC) $(CFLAGS) $(PROGSPECSD) -c $< -o $@ -I$(KERNEL_INCLUDES)
-
- ebtablesd: $(OBJECTS) ebtablesd.o libebtc.so
-- $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
-- -Wl,-rpath,$(LIBDIR)
-+ $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
-
- ebtables-restore.o: ebtables-restore.c include/ebtables_u.h
- $(CC) $(CFLAGS) $(PROGSPECS) -c $< -o $@ -I$(KERNEL_INCLUDES)
-
- ebtables-restore: $(OBJECTS) ebtables-restore.o libebtc.so
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
-- -Wl,-rpath,$(LIBDIR)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
-
- .PHONY: daemon
- daemon: ebtablesd ebtablesu