summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-07 19:14:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-07 19:14:17 +0000
commit871dd8ec7e7a5bcc6fb103d4beded98e6ab252b6 (patch)
treedc340c115fb996d7f6fa75fa0bc31afaed6857e6 /package/network
parented7c73fbefe240a6e3bcee4ebcbbe333f718b762 (diff)
downloadmaster-31e0f0ae-871dd8ec7e7a5bcc6fb103d4beded98e6ab252b6.tar.gz
master-31e0f0ae-871dd8ec7e7a5bcc6fb103d4beded98e6ab252b6.tar.bz2
master-31e0f0ae-871dd8ec7e7a5bcc6fb103d4beded98e6ab252b6.zip
uqmi: use -ffunction-sections and --gc-sections, reduces binary size from 57k to 29k
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41051
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/uqmi/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index 18e0954ad2..027fc0d1c2 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -34,7 +34,9 @@ define Package/uqmi/description
endef
TARGET_CFLAGS += \
- -I$(STAGING_DIR)/usr/include
+ -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += -Wl,--gc-sections
CMAKE_OPTIONS += \
-DDEBUG=1