summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-11-11 09:49:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-11-11 09:49:20 +0000
commit6966aa0d50fb96dbcdf8d574b2a91dd9f09742a4 (patch)
tree89b85882483b7e0afc2f77574eb57fc24110ea5a /package/network
parentda53ac677f479177455f77843f138d09225d46ec (diff)
downloadmaster-31e0f0ae-6966aa0d50fb96dbcdf8d574b2a91dd9f09742a4.tar.gz
master-31e0f0ae-6966aa0d50fb96dbcdf8d574b2a91dd9f09742a4.tar.bz2
master-31e0f0ae-6966aa0d50fb96dbcdf8d574b2a91dd9f09742a4.zip
lldpd: allow discovery protocols to be disabled from menuconfig
Signed-off-by: Michel Stam <m.stam@fugro.nl> [jow: fixed condition for CONFIG_LLDPD_WITH_JSON] Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43233
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/lldpd/Config.in28
-rw-r--r--package/network/services/lldpd/Makefile33
-rw-r--r--package/network/services/lldpd/patches/002-no-stack-protector.patch5
3 files changed, 60 insertions, 6 deletions
diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
new file mode 100644
index 0000000000..c7d47953af
--- /dev/null
+++ b/package/network/services/lldpd/Config.in
@@ -0,0 +1,28 @@
+menu "Configuration"
+ depends on PACKAGE_lldpd
+
+config LLDPD_WITH_CDP
+ bool
+ default y
+ prompt "Enable support for the Cisco Discovery Protocol (CDP) version 1 and 2"
+
+config LLDPD_WITH_FDP
+ bool
+ default y
+ prompt "Enable support for the Foundry Discovery Protocol (FDP)"
+
+config LLDPD_WITH_EDP
+ bool
+ default y
+ prompt "Enable support for the Extreme Discovery Protocol (EDP)"
+
+config LLDPD_WITH_SONMP
+ bool
+ default y
+ prompt "Enable support for the SynOptics Network Management Protocol"
+
+config LLDPD_WITH_JSON
+ bool
+ prompt "Enable JSON output for the LLDP Command-Line Interface"
+ default n
+endmenu
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 3a2e41122d..cffae63dfd 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lldpd
-PKG_VERSION:=0.7.7
+PKG_VERSION:=0.7.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=9031734c69940dd79a0a175123275f83
+PKG_MD5SUM:=508f2e76703abf8420d9223aae3db548
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
@@ -31,8 +31,13 @@ define Package/lldpd
SUBMENU:=Routing and Redirection
TITLE:=Link Layer Discovery Protocol daemon
URL:=https://github.com/vincentbernat/lldpd/wiki
- DEPENDS:=+libevent2 +USE_EGLIBC:libbsd
+ DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
USERID:=lldp=121:lldp=129
+ MENU:=1
+endef
+
+define Package/lldpd/config
+source "$(SOURCE)/Config.in"
endef
define Package/lldpd/description
@@ -46,12 +51,25 @@ endef
define Package/lldpd/install
$(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_DIR) $(1)/etc/lldpd.d
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
$(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
$(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
+ifneq ($(CONFIG_LLDPD_WITH_CDP),y)
+ sed -i -e '/cdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_FDP),y)
+ sed -i -e '/fdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_EDP),y)
+ sed -i -e '/edp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_SONMP),y)
+ sed -i -e '/sonmp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
endef
define Package/lldpd/conffiles
@@ -62,6 +80,13 @@ CONFIGURE_ARGS += \
--with-privsep-user=lldp \
--with-privsep-group=lldp \
--with-privsep-chroot=/var/run/lldp \
- --with-readline=no
+ --with-readline=no \
+ --with-embedded-libevent=no \
+ $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
+ $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
+ $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+ $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
+ $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
+
$(eval $(call BuildPackage,lldpd))
diff --git a/package/network/services/lldpd/patches/002-no-stack-protector.patch b/package/network/services/lldpd/patches/002-no-stack-protector.patch
index dc861bac64..8a49d2d134 100644
--- a/package/network/services/lldpd/patches/002-no-stack-protector.patch
+++ b/package/network/services/lldpd/patches/002-no-stack-protector.patch
@@ -1,10 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -62,7 +62,6 @@ AX_CFLAGS_GCC_OPTION([-Wformat])
+@@ -62,7 +62,5 @@ AX_CFLAGS_GCC_OPTION([-Wformat])
AX_CFLAGS_GCC_OPTION([-Wformat-security])
AX_CFLAGS_GCC_OPTION([-Wcast-align])
AX_CFLAGS_GCC_OPTION([-Winline])
-AX_CFLAGS_GCC_OPTION([-fstack-protector])
+-AX_CFLAGS_GCC_OPTION([-fstack-protector-strong])
+ AX_CFLAGS_GCC_OPTION([-fno-omit-frame-pointer])
AX_CFLAGS_GCC_OPTION([-D_FORTIFY_SOURCE=2])
- AX_CFLAGS_GCC_OPTION([-Wdeclaration-after-statement])
AX_CFLAGS_GCC_OPTION([-Wno-unused-parameter])