summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-29 14:40:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-29 14:40:04 +0000
commit65657fb5853869205ff6a1a2358a115990688d6d (patch)
treee2c7f736b4db8ffb2883cafa0d9b0b5446215b29 /package/network
parentc16879a385bcdeee426b2b7f0be89f0320b63c81 (diff)
downloadmaster-31e0f0ae-65657fb5853869205ff6a1a2358a115990688d6d.tar.gz
master-31e0f0ae-65657fb5853869205ff6a1a2358a115990688d6d.tar.bz2
master-31e0f0ae-65657fb5853869205ff6a1a2358a115990688d6d.zip
netifd: update to latest version
fixes DNS servers on reload (#12910) fixes ubus object race on reload or down/up (#12612) SVN-Revision: 35383
Diffstat (limited to 'package/network')
-rw-r--r--package/network/config/netifd/Makefile4
-rwxr-xr-xpackage/network/config/netifd/files/sbin/ifstatus2
-rwxr-xr-xpackage/network/config/netifd/files/sbin/ifup6
3 files changed, 6 insertions, 6 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index af50d4d28e..b5dd767f7e 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2013-01-29.1
+PKG_VERSION:=2013-01-29.2
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=3ae15bc2b82fe32188f726ceabcb1883276a5aed
+PKG_SOURCE_VERSION:=4bb99d4eb462776336928392010b372236ac3c93
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
# PKG_MIRROR_MD5SUM:=
diff --git a/package/network/config/netifd/files/sbin/ifstatus b/package/network/config/netifd/files/sbin/ifstatus
index 511cc1d8d9..8a951e6e15 100755
--- a/package/network/config/netifd/files/sbin/ifstatus
+++ b/package/network/config/netifd/files/sbin/ifstatus
@@ -10,4 +10,4 @@ ubus -S list "network.interface.$INTERFACE" >/dev/null || {
echo "Interface $INTERFACE not found"
exit 1
}
-ubus call network.interface."$INTERFACE" status
+ubus call network.interface status "{ \"interface\" : \"$INTERFACE\" }"
diff --git a/package/network/config/netifd/files/sbin/ifup b/package/network/config/netifd/files/sbin/ifup
index e6dbb35417..af3aaa8453 100755
--- a/package/network/config/netifd/files/sbin/ifup
+++ b/package/network/config/netifd/files/sbin/ifup
@@ -6,7 +6,7 @@ setup_wifi=
if_call() {
local interface="$1"
for mode in $modes; do
- ubus call $interface $mode
+ ubus call network.interface $mode "{ \"interface\" : \"$interface\" }"
done
}
@@ -38,7 +38,7 @@ done
[ "$modes" = "down up" ] && ubus call network reload
if [ -n "$ifup_all" ]; then
for interface in `ubus -S list 'network.interface.*'`; do
- if_call "$interface"
+ if_call "${interface##network.interface.}"
done
[ -n "$setup_wifi" ] && /sbin/wifi up
exit
@@ -47,7 +47,7 @@ else
echo "Interface $1 not found"
exit
}
- if_call "network.interface.$1"
+ if_call "$1"
fi
if [ -n "$setup_wifi" ] && grep -sq config /etc/config/wireless; then