summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-16 19:04:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-16 19:04:19 +0000
commit59cab6dd4820243e4828bed5dcd120fe05310725 (patch)
treec6acb1eca55293bc62b99c0279c1679ef80b31bb /package/network
parent71c8ec020dba204f96e4d680c2ea91f23e5588f3 (diff)
downloadmaster-31e0f0ae-59cab6dd4820243e4828bed5dcd120fe05310725.tar.gz
master-31e0f0ae-59cab6dd4820243e4828bed5dcd120fe05310725.tar.bz2
master-31e0f0ae-59cab6dd4820243e4828bed5dcd120fe05310725.zip
dnsmasq: support and use local-service by default (#14951)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43982
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dnsmasq/Makefile4
-rw-r--r--package/network/services/dnsmasq/files/dhcp.conf1
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq.init1
3 files changed, 4 insertions, 2 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 766aaf04ec..dcbb63a0f3 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.72
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/files/dhcp.conf b/package/network/services/dnsmasq/files/dhcp.conf
index 660b06ad4f..a6e7867ca7 100644
--- a/package/network/services/dnsmasq/files/dhcp.conf
+++ b/package/network/services/dnsmasq/files/dhcp.conf
@@ -19,6 +19,7 @@ config dnsmasq
#list interface br-lan
#list notinterface lo
#list bogusnxdomain '64.94.110.11'
+ option localservice 1 # disable to allow DNS requests from non-loclal subnets
config dhcp lan
option interface lan
diff --git a/package/network/services/dnsmasq/files/dnsmasq.init b/package/network/services/dnsmasq/files/dnsmasq.init
index 209952b5e6..cb78e831d3 100644
--- a/package/network/services/dnsmasq/files/dnsmasq.init
+++ b/package/network/services/dnsmasq/files/dnsmasq.init
@@ -127,6 +127,7 @@ dnsmasq() {
append_bool "$cfg" nonwildcard "--bind-interfaces"
append_bool "$cfg" fqdn "--dhcp-fqdn"
append_bool "$cfg" proxydnssec "--proxy-dnssec"
+ append_bool "$cfg" localservice "--local-service"
append_parm "$cfg" dhcpscript "--dhcp-script"
append_parm "$cfg" cachesize "--cache-size"