summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorDario Ernst <Dario.Ernst@riverbed.com>2016-05-24 16:06:07 +0200
committerJo-Philipp Wich <jo@mein.io>2016-05-24 16:31:17 +0200
commit4d1c75c601b3675f802ff3e7658e46be9aeabd6b (patch)
treea7e0779b934d5e85d64d00299a43a33383c7e69b /package/network
parent1012701014bd944197031a3c0023527861b521b4 (diff)
downloadmaster-31e0f0ae-4d1c75c601b3675f802ff3e7658e46be9aeabd6b.tar.gz
master-31e0f0ae-4d1c75c601b3675f802ff3e7658e46be9aeabd6b.tar.bz2
master-31e0f0ae-4d1c75c601b3675f802ff3e7658e46be9aeabd6b.zip
dropbear: Fix incorrect CONFIG_TARGET_INIT_PATH.
Fix a „semantic typo“ introduced in b78aae793e20e06defa1e75ab4d30dbb6807c139, where TARGET_INIT_PATH was used instead of CONFIG_TARGET_INIT_PATH. Signed-off-by: Dario Ernst <Dario.Ernst@riverbed.com>
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/dropbear/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index 6e5112c67f..9d62e926b4 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -78,13 +78,13 @@ CONFIGURE_ARGS += \
--disable-zlib \
--enable-bundled-libtom
-TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
+TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(CONFIG_TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
define Build/Configure
$(Build/Configure/Default)
- $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(TARGET_INIT_PATH)",g' \
+ $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(CONFIG_TARGET_INIT_PATH)",g' \
$(PKG_BUILD_DIR)/options.h
awk 'BEGIN { rc = 1 } \