summaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-01-17 10:58:34 +0000
committerSteven Barth <cyrus@openwrt.org>2015-01-17 10:58:34 +0000
commit18f76fbef178831085ffa5d6a3783b2f20c9dbfa (patch)
treec19404358afc9d64166d8dc8faba909de6212aee /package/network
parentd644d1bd5e8d5fd81656fb3080afacb3dcd13034 (diff)
downloadmaster-31e0f0ae-18f76fbef178831085ffa5d6a3783b2f20c9dbfa.tar.gz
master-31e0f0ae-18f76fbef178831085ffa5d6a3783b2f20c9dbfa.tar.bz2
master-31e0f0ae-18f76fbef178831085ffa5d6a3783b2f20c9dbfa.zip
iproute2: add package for bridge program
The 'bridge' program has been part of iproute2 for a while, and it was once declared[1] to the the intended longterm replacement for bridge-utils, but its features are still mostly distinct[2] from the venerable brctl. [1] http://lwn.net/Articles/435845/ [2] http://sgros-students.blogspot.com/2013/11/comparison-of-brctl-and-bridge-commands.html Signed-off-by: Russell Senior <russell@personaltelco.net> SVN-Revision: 43993
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iproute2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index a49b0616ea..ad14ac4484 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -58,6 +58,11 @@ $(call Package/iproute2/Default)
TITLE:=General netlink utility frontend
endef
+define Package/ip-bridge
+$(call Package/iproute2/Default)
+ TITLE:=Bridge configuration utility from iproute2
+endef
+
define Package/ss
$(call Package/iproute2/Default)
TITLE:=Socket statistics utility
@@ -130,6 +135,11 @@ define Package/genl/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
endef
+define Package/ip-bridge/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bridge/bridge $(1)/usr/sbin/
+endef
+
define Package/ss/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/ss $(1)/usr/sbin/
@@ -139,4 +149,5 @@ $(eval $(call BuildPackage,ip))
$(eval $(call BuildPackage,ip-full))
$(eval $(call BuildPackage,tc))
$(eval $(call BuildPackage,genl))
+$(eval $(call BuildPackage,ip-bridge))
$(eval $(call BuildPackage,ss))