summaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:51:57 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2016-04-17 12:51:57 +0000
commitba97a03d7d08bfd2a26ab2e7a83ef93dbf102cfe (patch)
tree9221319fedf7f6644b38d2aa7f317acd9872a1a6 /package/network/utils
parenta4d646cf155f187892b6461d364546957dafd59d (diff)
downloadmaster-31e0f0ae-ba97a03d7d08bfd2a26ab2e7a83ef93dbf102cfe.tar.gz
master-31e0f0ae-ba97a03d7d08bfd2a26ab2e7a83ef93dbf102cfe.tar.bz2
master-31e0f0ae-ba97a03d7d08bfd2a26ab2e7a83ef93dbf102cfe.zip
curl: add flags to allow gc-sections to strip out unused code
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 49184
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/curl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 319c0b710d..af38ed4aed 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -99,8 +99,9 @@ define Package/libcurl/config
source "$(SOURCE)/Config.in"
endef
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
+TARGET_LDFLAGS += -Wl,--gc-sections
CONFIGURE_ARGS += \
--disable-debug \