summaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorBert Vermeulen <bert@biot.com>2016-05-10 23:09:04 +0200
committerJohn Crispin <john@phrozen.org>2016-05-12 03:29:36 +0200
commitb4a23f83f92a42a4969a7c37d9985783234fd74f (patch)
tree7cf59f0cdb19e5949b65c316dbb3c8d165729813 /package/network/utils
parent8307c2fe686ded345c80318359d5b6679e581fa2 (diff)
downloadmaster-31e0f0ae-b4a23f83f92a42a4969a7c37d9985783234fd74f.tar.gz
master-31e0f0ae-b4a23f83f92a42a4969a7c37d9985783234fd74f.tar.bz2
master-31e0f0ae-b4a23f83f92a42a4969a7c37d9985783234fd74f.zip
iperf: Upgrade to version 2.0.8
The original iperf package is unmaintained. This switches to the "iperf2" project on sourceforge, a fork that started where the previous iperf left off. Version 2.0.8 fixes the issue that patch 002 handled, so that can be dropped. Due to a faulty check in configure.ac, this version needs _GNU_SOURCE defined to build properly against musl. Various other obsolete build options were also removed. Signed-off-by: Bert Vermeulen <bert@biot.com>
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/iperf/Makefile13
-rw-r--r--package/network/utils/iperf/patches/002-format-security.patch96
2 files changed, 5 insertions, 104 deletions
diff --git a/package/network/utils/iperf/Makefile b/package/network/utils/iperf/Makefile
index a3e0232d19..0085d34ba1 100644
--- a/package/network/utils/iperf/Makefile
+++ b/package/network/utils/iperf/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
-PKG_VERSION:=2.0.5
+PKG_VERSION:=2.0.8
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=44b5536b67719f4250faed632a3cd016
+PKG_SOURCE_URL:=@SF/iperf2
+PKG_MD5SUM:=e5887f799d8dc64a974c6c2f2e5cc339
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
PKG_LICENSE:=BSD-3-Clause
@@ -29,7 +29,7 @@ define Package/iperf/Default
CATEGORY:=Network
DEPENDS:= $(CXX_DEPENDS)
TITLE:=Internet Protocol bandwidth measuring tool
- URL:=http://sourceforge.net/projects/iperf/
+ URL:=http://sourceforge.net/projects/iperf2/
endef
define Package/iperf/Default/description
@@ -61,14 +61,11 @@ $(call Package/iperf/Default/description)
This package is built with multithread support.
endef
+TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += --disable-multicast
-CONFIGURE_VARS += ac_cv_func_malloc_0_nonnull=yes
ifeq ($(BUILD_VARIANT),single)
CONFIGURE_ARGS += --disable-threads
-else
- CONFIGURE_ARGS += --enable-threads=posix
- CONFIGURE_VARS += ac_cv_func_pthread_cancel=no
endif
CONFIGURE_VARS += CXXFLAGS="$$$$CXXFLAGS -fno-rtti"
diff --git a/package/network/utils/iperf/patches/002-format-security.patch b/package/network/utils/iperf/patches/002-format-security.patch
deleted file mode 100644
index 9331e54f5b..0000000000
--- a/package/network/utils/iperf/patches/002-format-security.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-Description: iperf format string FTBFS with -Werror=format-security
- Reported by Didier Raboud <odyx@debian.org>
-Author: Simon Paillard <spaillard@debian.org>
-Bug-Debian: http://bugs.debian.org/643408
-
---- a/compat/Thread.c
-+++ b/compat/Thread.c
-@@ -381,7 +381,7 @@ int thread_release_nonterm( int interrup
- Condition_Lock( thread_sNum_cond );
- thread_sNum -= nonterminating_num;
- if ( thread_sNum > 1 && nonterminating_num > 0 && interrupt != 0 ) {
-- fprintf( stderr, wait_server_threads );
-+ fprintf( stderr, "%s", wait_server_threads );
- }
- nonterminating_num = 0;
- Condition_Signal( &thread_sNum_cond );
---- a/src/ReportDefault.c
-+++ b/src/ReportDefault.c
-@@ -78,7 +78,7 @@ void reporter_printstats( Transfer_Info
- if ( stats->mUDP != (char)kMode_Server ) {
- // TCP Reporting
- if( !header_printed ) {
-- printf( report_bw_header);
-+ printf( "%s", report_bw_header);
- header_printed = 1;
- }
- printf( report_bw_format, stats->transferID,
-@@ -87,7 +87,7 @@ void reporter_printstats( Transfer_Info
- } else {
- // UDP Reporting
- if( !header_printed ) {
-- printf( report_bw_jitter_loss_header);
-+ printf( "%s", report_bw_jitter_loss_header);
- header_printed = 1;
- }
- printf( report_bw_jitter_loss_format, stats->transferID,
-@@ -159,7 +159,7 @@ void reporter_reportsettings( ReporterDa
- (data->mThreadMode == kMode_Listener ? 0 : 1) );
- win_requested = data->mTCPWin;
-
-- printf( separator_line );
-+ printf( "%s", separator_line );
- if ( data->mThreadMode == kMode_Listener ) {
- printf( server_port,
- (isUDP( data ) ? "UDP" : "TCP"),
-@@ -198,7 +198,7 @@ void reporter_reportsettings( ReporterDa
- printf( warn_window_requested, buffer );
- }
- printf( "\n" );
-- printf( separator_line );
-+ printf( "%s", separator_line );
- }
-
- /*
-@@ -286,7 +286,7 @@ void reporter_reportMSS( int inMSS, thre
- } else if ( checkMSS_MTU( inMSS, 576 ) ) {
- net = "minimum";
- mtu = 576;
-- printf( warn_no_pathmtu );
-+ printf( "%s", warn_no_pathmtu );
- } else {
- mtu = inMSS + 40;
- net = "unknown interface";
---- a/src/Reporter.c
-+++ b/src/Reporter.c
-@@ -901,7 +901,7 @@ void PrintMSS( ReporterData *stats ) {
- } else if ( checkMSS_MTU( inMSS, 576 ) ) {
- net = "minimum";
- mtu = 576;
-- printf( warn_no_pathmtu );
-+ printf( "%s", warn_no_pathmtu );
- } else {
- mtu = inMSS + 40;
- net = "unknown interface";
---- a/src/Settings.cpp
-+++ b/src/Settings.cpp
-@@ -375,8 +375,8 @@ void Settings_Interpret( char option, co
- break;
-
- case 'h': // print help and exit
-- fprintf(stderr, usage_long1);
-- fprintf(stderr, usage_long2);
-+ fprintf(stderr, "%s", usage_long1);
-+ fprintf(stderr, "%s", usage_long2);
- exit(1);
- break;
-
-@@ -482,7 +482,7 @@ void Settings_Interpret( char option, co
- break;
-
- case 'v': // print version and exit
-- fprintf( stderr, version );
-+ fprintf( stderr, "%s", version );
- exit(1);
- break;
-