summaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-21 10:15:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-21 10:15:10 +0000
commita9a9644efd21e9bd907055f42e6a4351c9f48fad (patch)
tree0fb024876ca29d6ee7005d2998361d0367660c56 /package/network/utils
parentfe7e52e4a4cf8734676eac908967796e29759447 (diff)
downloadmaster-31e0f0ae-a9a9644efd21e9bd907055f42e6a4351c9f48fad.tar.gz
master-31e0f0ae-a9a9644efd21e9bd907055f42e6a4351c9f48fad.tar.bz2
master-31e0f0ae-a9a9644efd21e9bd907055f42e6a4351c9f48fad.zip
iptables: use -ffunction-sections, -fdata-sections and --gc-sections
SVN-Revision: 36680
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/iptables/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index fb7aef9a01..a0ea7f7ce0 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.18
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
@@ -342,7 +342,11 @@ TARGET_CPPFLAGS := \
TARGET_CFLAGS += \
-I$(PKG_BUILD_DIR)/include \
- -I$(LINUX_DIR)/user_headers/include
+ -I$(LINUX_DIR)/user_headers/include \
+ -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += \
+ -Wl,--gc-sections
CONFIGURE_ARGS += \
--enable-shared \