summaryrefslogtreecommitdiffstats
path: root/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-01-17 12:29:26 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-01-17 12:29:26 +0000
commit3b798d819da47737262acb78738f048dae31bc30 (patch)
treef51257bed8f852fca3541cc2468eab930998f896 /package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
parent576aa2af0c217c5497cc61bce80331bcd824f735 (diff)
downloadmaster-31e0f0ae-3b798d819da47737262acb78738f048dae31bc30.tar.gz
master-31e0f0ae-3b798d819da47737262acb78738f048dae31bc30.tar.bz2
master-31e0f0ae-3b798d819da47737262acb78738f048dae31bc30.zip
xtables-addons: move to package/, add myself as maintainer
SVN-Revision: 35193
Diffstat (limited to 'package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch')
-rw-r--r--package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
new file mode 100644
index 0000000000..8dc6384478
--- /dev/null
+++ b/package/network/utils/xtables-addons/patches/002-fix-kernel-version-detection.patch
@@ -0,0 +1,22 @@
+--- a/configure
++++ b/configure
+@@ -11892,7 +11892,7 @@ regular_CFLAGS="-Wall -Waggregate-return
+ if test -n "$kbuilddir"; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
+ $as_echo_n "checking kernel version that we will build against... " >&6; }
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
+ kmajor="${krel%%[^0-9]*}";
+ kmajor="$(($kmajor+0))";
+ krel="${krel:${#kmajor}}";
+--- a/configure.ac
++++ b/configure.ac
+@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
+
+ if test -n "$kbuilddir"; then
+ AC_MSG_CHECKING([kernel version that we will build against])
+- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
++ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
+ kmajor="${krel%%[[^0-9]]*}";
+ kmajor="$(($kmajor+0))";
+ krel="${krel:${#kmajor}}";