summaryrefslogtreecommitdiffstats
path: root/package/network/utils/wpan-tools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-10 08:30:11 +0000
committerJohn Crispin <john@openwrt.org>2015-04-10 08:30:11 +0000
commite7559353dbfedc23ef9423006a744f090f23edec (patch)
tree8db0a59f36b30d2cd66d8b27fef4fdb2ffe704f0 /package/network/utils/wpan-tools
parent5471e15bdb92cbebb6d835ea2cdaf7d2e8f74ce2 (diff)
downloadmaster-31e0f0ae-e7559353dbfedc23ef9423006a744f090f23edec.tar.gz
master-31e0f0ae-e7559353dbfedc23ef9423006a744f090f23edec.tar.bz2
master-31e0f0ae-e7559353dbfedc23ef9423006a744f090f23edec.zip
wpan-tools: adds wpan-tools utility
This patch adds the wpan-tools (iwpan) utility to OpenWRT build system. This utility required to manage IEE-802.15.4 devices. Signed-off-by: Varka Bhadram <varkab@cdac.in> SVN-Revision: 45349
Diffstat (limited to 'package/network/utils/wpan-tools')
-rw-r--r--package/network/utils/wpan-tools/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/network/utils/wpan-tools/Makefile b/package/network/utils/wpan-tools/Makefile
new file mode 100644
index 0000000000..87a5fb1461
--- /dev/null
+++ b/package/network/utils/wpan-tools/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=wpan-tools
+PKG_VERSION:=0.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://wpan.cakelab.org/releases/
+PKG_MD5SUM:=37575523d1543e06b11295f03a891fa7
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/wpan-tools
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=cfg802154 interface configuration utility
+ URL:=http://wpan.cakelab.org/
+ DEPENDS:= +libnl
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default)
+endef
+
+define Package/wpan-tools/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iwpan $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,wpan-tools))