summaryrefslogtreecommitdiffstats
path: root/package/network/utils/tcpdump/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-22 07:51:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-22 07:51:15 +0000
commitbc1d72c7bf0f0c7de874f489c05b9304a1de1f7e (patch)
tree251cbce9c5911f8a85d0ab0b64ec3d403f29f6a2 /package/network/utils/tcpdump/Makefile
parent1941fb309df2dbede8fd3db97eccedf0bb455ede (diff)
downloadmaster-31e0f0ae-bc1d72c7bf0f0c7de874f489c05b9304a1de1f7e.tar.gz
master-31e0f0ae-bc1d72c7bf0f0c7de874f489c05b9304a1de1f7e.tar.bz2
master-31e0f0ae-bc1d72c7bf0f0c7de874f489c05b9304a1de1f7e.zip
tcpdump: add SLL parsing support to tcpdump-mini, use -ffunction-sections, -fdata-sections and --gc-sections to reduce size
SVN-Revision: 35288
Diffstat (limited to 'package/network/utils/tcpdump/Makefile')
-rw-r--r--package/network/utils/tcpdump/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/utils/tcpdump/Makefile b/package/network/utils/tcpdump/Makefile
index df1ee3c31b..b32d25f750 100644
--- a/package/network/utils/tcpdump/Makefile
+++ b/package/network/utils/tcpdump/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tcpdump
PKG_VERSION:=4.2.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
@@ -54,6 +54,9 @@ CONFIGURE_ARGS += \
--enable-ipv6
endif
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
CONFIGURE_VARS += \
BUILD_CC="$(TARGET_CC)" \
HOSTCC="$(HOSTCC)" \