summaryrefslogtreecommitdiffstats
path: root/package/network/utils/linux-atm/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-18 15:35:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-18 15:35:30 +0000
commitf6e38ec125ddb1da51780e510c7943e76f61f88d (patch)
tree6c41a713b5f83fce07f89604b16fe4385bf2db3c /package/network/utils/linux-atm/Makefile
parent262f054c6e556b3c4e5c2ec334f3f7190a5abf0f (diff)
downloadmaster-31e0f0ae-f6e38ec125ddb1da51780e510c7943e76f61f88d.tar.gz
master-31e0f0ae-f6e38ec125ddb1da51780e510c7943e76f61f88d.tar.bz2
master-31e0f0ae-f6e38ec125ddb1da51780e510c7943e76f61f88d.zip
br2684ctl: resolve a boot time race condition with nas0 bringup by using explicit notification when init is done
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48321
Diffstat (limited to 'package/network/utils/linux-atm/Makefile')
-rw-r--r--package/network/utils/linux-atm/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/linux-atm/Makefile b/package/network/utils/linux-atm/Makefile
index 9c6cfec95c..e081428eb0 100644
--- a/package/network/utils/linux-atm/Makefile
+++ b/package/network/utils/linux-atm/Makefile
@@ -178,10 +178,10 @@ define Package/atm-diagnostics/install
endef
define Package/br2684ctl/install
- $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/hotplug.d/atm
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/hotplug.d/atm $(1)/usr/sbin $(1)/lib/netifd
+ $(INSTALL_BIN) ./files/br2684-up $(1)/lib/netifd/br2684-up
$(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
$(INSTALL_DATA) ./files/atm.hotplug $(1)/etc/hotplug.d/atm/00-trigger
- $(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) \
./files/br2684ctl_wrap \
$(PKG_INSTALL_DIR)/usr/sbin/br2684ctl \