summaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-02 18:13:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-02 18:13:38 +0000
commit4b241e98270ab83dcae8e678ee8066d65fdb44eb (patch)
treee0925d805f41e08ab0864e247bb2485362095e38 /package/network/utils/iptables
parentae2c9a815a54a0d6e38e084a43d12476bfd265c6 (diff)
downloadmaster-31e0f0ae-4b241e98270ab83dcae8e678ee8066d65fdb44eb.tar.gz
master-31e0f0ae-4b241e98270ab83dcae8e678ee8066d65fdb44eb.tar.bz2
master-31e0f0ae-4b241e98270ab83dcae8e678ee8066d65fdb44eb.zip
netfilter: split off header matching modules not used by the default config (reduces rootfs size and memory usage)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40983
Diffstat (limited to 'package/network/utils/iptables')
-rw-r--r--package/network/utils/iptables/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 48b1879bd3..f6db428bcb 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -302,6 +302,16 @@ $(call Package/iptables/Default)
endef
+define Package/ip6tables-extra
+$(call Package/iptables/Default)
+ DEPENDS:=ip6tables +kmod-ip6tables-extra
+ TITLE:=IPv6 header matching modules
+endef
+
+define Package/ip6tables-mod-extra/description
+iptables header matching modules for IPv6
+endef
+
define Package/ip6tables-mod-nat
$(call Package/iptables/Default)
DEPENDS:=ip6tables +kmod-ipt-nat6
@@ -459,6 +469,7 @@ $(eval $(call BuildPlugin,iptables-mod-tproxy,$(IPT_TPROXY-m)))
$(eval $(call BuildPlugin,iptables-mod-tee,$(IPT_TEE-m)))
$(eval $(call BuildPlugin,iptables-mod-u32,$(IPT_U32-m)))
$(eval $(call BuildPackage,ip6tables))
+$(eval $(call BuildPlugin,ip6tables-extra,$(IPT_IPV6_EXTRA-m)))
$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))
$(eval $(call BuildPackage,libiptc))
$(eval $(call BuildPackage,libip4tc))